Page MenuHome

Crash Resetting / Unsetting Editor Type to default value
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu 18.04 Bionic
Kernel: 4.15.0-39-lowlatency
Graphics card:Radeon RX 560
Memory 12GB
AMD Ryzen 5 1400 Quad-Core Processor

Blender Version
2.80 Beta Downloaded 11/29/2018
Broken:
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
After clicking Unset Blender shuts down /closes/goes away
Exact steps for others to reproduce the error
Right click on hierarchy icon and select "unset" closes out blender
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.

Which icon do you mean by "hierarchy icon"?

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Confirmed, Medium.Nov 30 2018, 4:17 PM

Can confirm the issue.

Seems to happen in every editor except the 3d view.

# Blender 2.80 (sub 35), Commit date: 2018-11-30 11:03, Hash 0d88668617a

# backtrace
/home/jacques/blender-git/build_linux_debug/bin/blender(BLI_system_backtrace+0x35) [0x55a5c582bff5]
/home/jacques/blender-git/build_linux_debug/bin/blender(+0x1e2ab6f) [0x55a5c43e1b6f]
/home/jacques/blender-git/build_linux_debug/bin/blender(+0x1e2ad6e) [0x55a5c43e1d6e]
/lib/x86_64-linux-gnu/libc.so.6(+0x3ef20) [0x7f200b5b2f20]
/home/jacques/blender-git/build_linux_debug/bin/blender(ED_render_scene_update+0x1c6) [0x55a5c49e5ba9]
/home/jacques/blender-git/build_linux_debug/bin/blender(_ZN3DEG24deg_editors_scene_updateEPK22DEGEditorUpdateContextb+0x33) [0x55a5c583ec8f]
/home/jacques/blender-git/build_linux_debug/bin/blender(DEG_ids_check_recalc+0xa4) [0x55a5c584ada1]
/home/jacques/blender-git/build_linux_debug/bin/blender(BKE_scene_graph_update_tagged+0xf6) [0x55a5c5469aed]
/home/jacques/blender-git/build_linux_debug/bin/blender(wm_event_do_depsgraph+0x143) [0x55a5c43e69c1]
/home/jacques/blender-git/build_linux_debug/bin/blender(wm_event_do_refresh_wm_and_depsgraph+0xca) [0x55a5c43e6aa6]
/home/jacques/blender-git/build_linux_debug/bin/blender(wm_event_do_notifiers+0x82c) [0x55a5c43e72e6]
/home/jacques/blender-git/build_linux_debug/bin/blender(WM_main+0x3c) [0x55a5c43e2bfd]
/home/jacques/blender-git/build_linux_debug/bin/blender(+0x1e26538) [0x55a5c43dd538]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7f200b595b97]
/home/jacques/blender-git/build_linux_debug/bin/blender(_start+0x2a) [0x55a5c43dceba]

I think the crash happens because the default spacetype is SPACE_VIEW3D (RNA_screen.c lines 369++ in blender2.8) and, for example, when we are in UV images editor and that we unset, blender tries to draw SPACE_VIEW3D whereas no rv3d is available yet. Maybe this property in RNA_screen:

prop = RNA_def_property(srna, "type", PROP_ENUM, PROP_NONE);
RNA_def_property_enum_sdna(prop, NULL, "spacetype");

shouldn't be EDITABLE (The goal is that when we click on Unset, it does nothing)

But I tried this:

RNA_def_property_clear_flag(prop, PROP_ANIMATABLE | PROP_EDITABLE);

and it doesn't fix the bug, and I don't really know why it doesn't work...

Brecht Van Lommel (brecht) closed this task as Resolved.
Brecht Van Lommel (brecht) claimed this task.

It seems this no longer crashes.