Page MenuHome

horizontal scrollbar outliner obstructs items
Closed, ResolvedPublic

Description

System Information
Operating system: all
Graphics card: n.a.

Blender Version
Broken: daily 2.80 versions

Short description of error
horizontal outliner scrollbar superimposes on underlaying items.
on smaller screens with not much room for the outliner, you can’t select items under the scrollbar.
there needs to be dedicated space or whenever the horizontal scrollbar appears, the itemlist should move up..

Exact steps for others to reproduce the error
make outliner small enough so hor. scrollbar appears.
create obects/mods to fill up outliner
observe last item is unselectable (overlays it)

Details

Type
Bug

Related Objects

Event Timeline

Roel Koster (kostex) reopened this task as Open.Nov 30 2018, 4:52 PM

ok.. this is really getting on my nerves.. sorry that I freak out now, but it’s really just a throw of a dice with trying to inform you about a bug/feature/ui issue/papercut or whatever you think you call something.
then it’s a feature, then it’s a bug, always just the opposite of what I think it is..

I have submitted the patch for the vertical scrollbar a while ago and stated that someone needs to look at the horizontal too because I’m too stupid to code it myself.. brecht closed it when my patch was committed.. after a while I decided to open it again (today) because noone did anything.
brecht closed it right away (today) stating that was not the place to report THIS BUG..

so I submitted a bug report here and now this...
You reaally need to be a friend of the family to be taken seriously here.. that SUCKS!

The right thing for you all was not to close it all off but take a very small step toward placing it under the right label. I’m trying to help look for issues and tell you about my findings.. this is not the first time I get these kinds of close-offs..

a while ago someone insisted on attaching a blend file.. while it made no sense to do so.. all these things pile up to extreme frustration with you (blender dev team)

not a bug.. djeez..

Brecht Van Lommel (brecht) triaged this task as Confirmed, Medium priority.Dec 5 2018, 6:56 PM
gsr b3d (gsrb3d) closed this task as Resolved.

Bug fixed by D4202