Page MenuHome

Dyntopo resolution don't work when using anchored or drag dot stroke methods
Closed, InvalidPublic

Description

While in sculpt mode, dyntopo activated, resolution works for any given refine method but when anchored or drag dot stroke methods are used, the brush resolution stops working and reamains at a fixed resolution even though the resolution value is changed. It seems as if dyntopo is deactivated when chosing anchored or drag dot stroke methods

Details

Type
Bug

Event Timeline

Juan Romero (onnevan) renamed this task from Dyntopo resolution don't work when using a texture brush to Dyntopo resolution don't work when using anchored or drag dot stroke methods.
Juan Romero (onnevan) updated the task description. (Show Details)
Sebastian Parborg (zeddb) claimed this task.

Those two methods can not easily be implemented with dynamic topology. We would have to tessellate the mesh and undo the tessellation right after if the user moves the position of the stroke.
Dynatopo were not built for these kinds of situations. So this is more of a feature request: https://blender.community/c/rightclickselect/

Fine, then. A bit of a shame because those are very useful methods for esculpting with alphas. Anyway, wouldn't it be better if at least they had a small warning or text beside stating "no dyntopo stroke" or something?

I'm not saying that it absolutely couldn't be implemented, it's just that this is not really a bug but a limitation in how dynatopo works.
(So it is working as intended, just not in the way a user would want it to)

Because of this, fixing it will not be a priority during the stabilization of the 2.8 beta.

So my suggestion to you:

  1. Create a nice proposal of features that you want in blender sculpt mode over at rightclickselect
  2. Iterate a few times with the community and drum up support for your requested features
  3. When the proposal has gained enough support a developer will have a nice list of what to improve/implement

I think this is the best way for you to get what you want. Unless you want to program it in yourself.