Page MenuHome

2.78 Texture paint crashes blender
Closed, ArchivedPublic

Description

Hi,

Imported a simple project I was working on from 2.78ish to 2.80 beta to have a play. What when I attempted to Texture paint it almost always crashes Blender. Sometimes the beach ball shows and it recovers - other times it beach balls forever other times it crashes immediately.

I am a casual user so it may just be setup incorrectly - UV etc - however obviously we don't want Blender cashing on people ;)

Hope that is helpful. Keep up the excellent work it is looking great.

System Information
Operating system:
Graphics card:

Blender Version
Broken:
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.

Can't reproduce it yet, maybe because the textures are missing.
Please pack the textures into the .blend file and upload it again.

Also what do you do exactly to make it crash. Just entering texture paint mode, or start drawing, and on which object?

Maybe you could also simplify the file a bit (removing objects that are not needed to reproduce the crash).

Thanks.

Elton F (javawocky) added a comment.EditedDec 1 2018, 10:39 PM

Thanks for taking a look Jacques,

I have taken a screen grab on my machine of how to reproduce it. Pretty much seams to be open the file - select text mode - enter edit mode with tab - back to text mode and start painting and it crashes.

Here is the screen grab https://youtu.be/DgOG4GpS0WI
macOS

Cheers.

Can't reproduce it yet, maybe because the textures are missing.
Please pack the textures into the .blend file and upload it again.
Also what do you do exactly to make it crash. Just entering texture paint mode, or start drawing, and on which object?
Maybe you could also simplify the file a bit (removing objects that are not needed to reproduce the crash).
Thanks.

Videos and/or links to external sites etc. are not acceptable as bug report (they can be provided as additional information only).

We requested a .blend file with packed textures, not a video…

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.