Page MenuHome

Inconsistent Color management behavior for textures between Solid and Eevee
Open, ConfirmedPublic

Description

System Information
Operating system: Win7
Graphics card: GeForce GTX 1070

Blender Version
2.80
2018-11-30 22:29
0f5b53ba4dc

Description
Color management, at least when it comes to textures, is inconsistent between Solid mode and Eevee, and weird stuff happens when changing Display Device in Color Management and switching back and forth between Solid and Eevee.
It's a bit confusing to describe so here's a short video to demonstrate: https://my.mixtape.moe/xvblgn.webm

Exact steps for others to reproduce the error

  1. Open the attached file. You'll (probably) see that the texture displayed on the cube is washed out.
  2. Now go to Render properties, and under Color Management, change Display Device to None. Now the texture colors will look correct.
  3. Change the Display Device back to sRGB. Switch to Eevee. Note that the texture looks correct.
  4. Change the Display Device to None. The texture will now look overly dark.
  5. Switch back to Solid mode. The texture looks correct with this Display Device, like before.
  6. Switch to Eevee once again. The texture should look correct now, which contradicts what we saw in step 4.
  7. Change Display Device to sRGB, and now it will look washed out in Eevee. If you switch back to Solid mode, then back to Eevee, the colors will once again be correct.

Also, performing certain actions seems to make the texture look correct in Eevee as well. If you get to step 5, then undo something, or change a material property, the texture will suddenly look correct.

Details

Type
Bug

Event Timeline

Tbh I don't know what this should look like but it seems a bit weird.

@Clément Foucault (fclem), can you take a look please?

Philipp Oeser (lichtwerk) triaged this task as Confirmed priority.Dec 6 2018, 12:35 PM

Even though I still struggle with CM a bit, I would also expect textures in 3DView + Solid Shading + Flat Lighting + Texture Color to display as in the Image Editor...

adding @Sergey Sharybin (sergey) and @Brecht Van Lommel (brecht) here for further advice...

@Brecht Van Lommel (brecht), i've just committed changes which i think implements what we've discussed here. Afraid, now you're the best person to answer the question whether things behave as they are designed to.

Well (from a users perspective) as of rB4c336f034e35 the textures still display washed out in 3DView + Solid Shading + Flat Lighting + Texture Color [but I dont know what has been discussed ;)]