Page MenuHome

screen.screen_full_area flickering
Closed, ArchivedPublic

Description

System Information
Operating system: gentoo linux
Graphics card: 1060

Blender Version
Broken: 2.8
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional) 2.7*

Short description of error
I want to tune screen.screen_full_area toggle like in 2.7* But it don't toggle, it flickering and randomly stop in one of 2 modes (full and standart)
Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
assign some hotkey to screen.screen_full_area

Details

Type
Bug

Event Timeline

Seems to work for me. Is this what you tried to do?

Yes
I have bug with all keys
Do you on linux?

Sebastian Parborg (zeddb) triaged this task as Confirmed priority.EditedFri, Dec 7, 4:18 PM

@brothermechanic (brothermechanic) I can reproduce this on Linux too. However, the problem was the the action was set to "Any" and not "Press" as in @Jacques Lucke (JacquesLucke) example.

So the shortcut would trigger on both key press and release (and hold and dubble tap etc). So this is not a bug really.

@Campbell Barton (campbellbarton) I'm guessing this can just be closed it that was the case.

Brecht Van Lommel (brecht) closed this task as Archived.Fri, Dec 7, 4:27 PM

Right, don't edit the action zone keymap item. It's a bit confusing to have this in the keymap at all, but not a bug.