Page MenuHome

Unable to switch between 2 objects without going through Object mode.
Closed, ArchivedPublic

Description

System Information
Operating system: win 7
Graphics card: gtx 550ti

Blender Version
Broken: Blender 2.8 beta

Worked: (optional) Blender 2.79 latest master

Short description of error

Unable to switch between 2 objects without going through Object mode.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

This is for me the biggest regression so far i mentioned it before, but somehow it didn't get enough attention -> https://developer.blender.org/T56744#536291

This is one the feature that help us in Blender to work fast while sculpting or bones weight painting . And this is the way we make good use of right click select and left click action. Explained at length here -> https://vimeo.com/76335056

In Blender 2.79:
First case: working with 2 or more meshes

  1. Select 1 mesh go to sculpt mode and do some sculpts and
  2. Select another mesh go to sculpt mode with this second mesh and do some work as well
  3. Now select the first mesh you will see that with the first mesh selected you enter straight to sculpt mode no need to through object mode.

Try the same thing in Blender 2.8.35
You will see that to move from step 2 to 3 you have to go through object mode, select the second object and switch to sculpt mode every times you will need to switch you have to go through object mode and so on.

Second case: skinning ( weighing your character)

In Blender 2.79, after parenting your mesh to your armature do this:

  1. select the mesh go to weigh paint mode and
  2. Select your armature go to pose mode
  3. Now with left click you can paint and with right click you can select individual bones

Now Try the same thing in Blender 2.80.35, you see that you cannot select your bones :(
In Blender 2.80.35 since you cannot select a bone while your mesh is in weigh painting mode you are stuck with selecting via vertex group and a rigged character can have easily 50 bones and you have scroll or well remember your vertex group (bone's name)

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.EditedDec 1 2018, 6:18 PM
Brecht Van Lommel (brecht) claimed this task.

These things work different in 2.8:

  • First case: disabled Edit > Lock Object Modes. Eventually multi-object sculpting will be supported too.
  • Second case: select armature, select mesh, enter weight paint mode. The armature will now be in pose mode automatically.

First case: disabled Edit > Lock Object Modes. Eventually multi-object sculpting will be supported too.

What do you mean by this? Should i lock Object mode somehow or ... ?

Second case: select armature, select mesh, enter weight paint mode. The armature will now be in pose mode automatically.

How do you select individual bone when you are in weight painting mode?

What do you mean by this? Should i lock Object mode somehow or ... ?

Go to the Edit menu at the top of the screen and disable it.

How do you select individual bone when you are in weight painting mode?

Same as before for right click select, Ctrl+LMB for left click select.

For rigging it solved but the "Edit menu at the top" i cannot find it. Here is my screen shots can you point where that button is?

Year, being able to switch from one object to another whithout changing modes is fundamental while sculpting. I am curious also.

Look at the top left of you screenshot: File, Edit, ..

Oh, @Erick Tukuniata (erickblender) I found, its a really hidden setting, I guess it should be disabled by default, it is a fundamental fature.

I found it Thanks :) . This is getting pretty ridiculous, this is me in Blender 2.8 right now LOL https://media.giphy.com/media/26tP6eYNrkMhUsvJu/giphy-downsized-large.gif

Year, being able to switch from one object to another whithout changing modes is fundamental while sculpting. I am curious also.

A hint for you, when using dyntopo you have to go edit mode from time to time to update your mesh, this is a regression.

Oh, @Erick Tukuniata (erickblender) I found, its a really hidden setting, I guess it should be disabled by default, it is a fundamental fature.

Well, it's not hidden, but I was almost literally hitting my head against the wall because of that! Should really be disabled by default, what's the pros on that lock feature?