Page MenuHome

Multires: changes not smoothly propagated from low to high, for example with apply base
Closed, ResolvedPublicBUG

Authored By
Ismael Fuentes (Isfuelo)
Dec 1 2018, 10:20 PM
Tokens
"Love" token, awarded by gritche."Love" token, awarded by Jaydead."Like" token, awarded by vitos1k."Love" token, awarded by hitrpr."Party Time" token, awarded by jfmatheu."Party Time" token, awarded by crantisz."Love" token, awarded by S_Jockey."The World Burns" token, awarded by LapisSea."Burninate" token, awarded by AlRedd."Burninate" token, awarded by Rub."Burninate" token, awarded by Alrob."Burninate" token, awarded by unumex."100" token, awarded by aftamat4ik."Like" token, awarded by Leul."Like" token, awarded by monio."Burninate" token, awarded by plundh."Burninate" token, awarded by lucasfalcao."Burninate" token, awarded by ebarranco."Burninate" token, awarded by viadvena."Like" token, awarded by knightknight."Burninate" token, awarded by TheCharacterhero."Burninate" token, awarded by brilliant_ape."Like" token, awarded by andruxa696."Burninate" token, awarded by VertexPainter."Burninate" token, awarded by Lumpengnom."Like" token, awarded by julperado."Burninate" token, awarded by Frozen_Death_Knight."Burninate" token, awarded by MetinSeven."Like" token, awarded by ncthbrt.

Description

System Information
Operating system: Windows 10
Graphics card: Nvidia GeForce TITAN Black 32GB RAM

Blender Version
Broken: 2.80 Beta, 0f5b53ba4dc, blender2.8, 2018-11-30
Worked: (optional)

Short description of error
Apply Base malfunction in the multiresolution modifier.
I have also noticed that the polygon counter does not work in sculpt mode.

Exact steps for others to reproduce the error

  • New scene with general design.
  • Ctrl + 5 to subdivide the cube.
  • Apply Subdivision modifier.
  • Add multiresolution modifier and subdivide 5 times. Tris: 12,582,912
  • The right button of the mouse. Smoth Shading.
  • Change to "sculpting" workspace.
  • Select the Grab brush and move the mesh.
  • In the multires modifier press "Apply Base"
  • The mesh is deformed in a strange way.

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

Hey @Sergey Sharybin (sergey) any ETA on when this will be fixed? Just curious :)

@Alan Redd (AlRedd), the proper fix will be started to be worked on as soon as 2.81 tasks are tackled.

@Alan Redd (AlRedd), the proper fix will be started to be worked on as soon as 2.81 tasks are tackled.

That's great to know! Thank you for your reply! :)

If preview level is set to zero, artifacts are less important, less problematic and can be smoothed.
In 2.81, you could greyed out button when preview level is not equal to zero.

so now it will be fixed only in 2.82? this is worst bug i ever had in sculpting and now no one knows how to fix it.

Igor (unumex) awarded a token.
dupoxy added a subscriber: dupoxy.Nov 29 2019, 5:19 PM
This comment was removed by Alan Redd (AlRedd).

Any news on this? I'm still jumping between 2.79 and 2.81 only because of this multires issue. 2.79 has problems too but at least I can navigate around them and get good results.
As a generalist that uses sculpting only on some client projects, I can't afford a Zbrush/3DCoat license (though I really want one now). And I'm pretty sure that like me there are also many users that need and depend on this functionality simply because they can't afford other options... :(

if I understand correctly, it is pretty hard to fix because code is old , changed few times by different people, + it is complicated and messed up. I also think that multires very important for production quality models. I was think it will be fixed in 2.80, then 2.81 and now seems it will not be fixed in 2.82. If it is so complicated to fix, and even after it will be fixed, what if there will be need to add new features like layer sculpting (blendshapes) or vertex color support in multires. Will it be again so complicated and maybe even not possible to implement?
Maybe it is a good reason to try discuss possibility of new implementation of multires? there is some open source examples, where can be find inspiration, basic implementation for new better Multires with more structured and simplified code .
Maybe we can ask for help Stephane Ginier , developer of SculptGL.
Thanks for your time, also thanks to Sergey Sharybin and Pablo Dobarro for their hard work.

I absolutely agree. Multires badly needs some love.

Maybe it is a good reason to try discuss possibility of new implementation of multires? there is some open source examples, where can be find inspiration, basic implementation for new better Multires with more structured and simplified code .

Deprecating the current implementation and starting clean sounds like the right way to go about it in the long run but it leaves artists with no fully functioning multires for an even longer time.
Another thing to consider is a fundamental redesign to better accommodate support for mesh data such as vertex color and shape keys. For example, associating multires to the mesh data rather than the modifier stack as it would act a lot more like an extension of mesh data rather than a topology modification. (that is only if support for vertex paint and such is in mind)

Yo @Dalai Felinto (dfelinto) Can you keep us update on this email

Hi Pablo,

I really appreciate your enthusiasm for the sculpting/painting system, as
well as your concern with the overall quality of Blender. If you think
multires is on the way of the sculpting development, and I trust you on
this, I will need your help to understand what exactly needs to be done
here.

There are enough people that can help you implementing that, once the issue
is more clear. So don't worry about lacking the necessary knowledge at the
moment. Also, don't worry about the required time. As you pointed out, this
seems important enough to justify you focusing on that over the other
features.

I will call you tomorrow to talk about that,
Dalai

Do we still have some kind of hope?

@Erick Tukuniata (erickblender) better if we keep the discussions where they originated. I will write an update to bf-committers now. Thanks for the reminder.

This is not happening for 2.82 since we are in bugfixing only phase now, and this is a bigger change.

there are few suggetions for people that has this bug:
For example you have already made model with hires modifier and you want to use Apply Base on it. Like this one


If you just press that button it will ... destroy your sculpt -

But! If you first sculpt something on model ... something, whatever it is

And only then press Apply Base - everything will be ok.

This is after i pressed Apply Base. as you see all sculpt data is on it's place. But topology of mesh is changed. Probably when blender activates sculpt mode it is not load all the sculpt data or... something like this.

there is still problems, if you press Aplly Base 5-6 times it will destroy your mesh like this:

More times you press Aplly Base - more distortion you will get.

Maybe there is a way to... fix positions of lowpoly mesh vertexes by binding them to some closest vertexes of highpoly mesh from multires? And when user press Apply Base it should move only when that highpoly mesh vertexes are moved... (sorry for my english). I don't want to install visual studio and else things because by pc has no memory left on c drive. But i want to fix it, ofk. Because Multires modifier is very useful for making Normal Maps, paint some scars, pores and other things. Dyntopo is great but there is a lot of situations where you cannot remesh your model every time you change it. + baking normal map from multires is faster + very accurate (maybe in future we will have baking AO or Cavity maps from multires, i hope).

For tests i used latest blender 2.82 beta build from Blender.org, blender-2.82-81b7f8efaf7a-windows64
I don't know why, but someone removed old level switch feature frob Multires. This how it was(in 06 month of 2.8 build) -


And now how it is -

I don't know who and why done this. Because bug is still in place, but no level switching anymore.... Why? Please, at least return this level switch to us.

there are few suggetions for people that has this bug:
For example you have already made model with hires modifier and you want to use Apply Base on it. Like this one


If you just press that button it will ... destroy your sculpt -

But! If you first sculpt something on model ... something, whatever it is

And only then press Apply Base - everything will be ok.

This is after i pressed Apply Base. as you see all sculpt data is on it's place. But topology of mesh is changed. Probably when blender activates sculpt mode it is not load all the sculpt data or... something like this.

there is still problems, if you press Aplly Base 5-6 times it will destroy your mesh like this:

More times you press Aplly Base - more distortion you will get.

Maybe there is a way to... fix positions of lowpoly mesh vertexes by binding them to some closest vertexes of highpoly mesh from multires? And when user press Apply Base it should move only when that highpoly mesh vertexes are moved... (sorry for my english). I don't want to install visual studio and else things because by pc has no memory left on c drive. But i want to fix it, ofk. Because Multires modifier is very useful for making Normal Maps, paint some scars, pores and other things. Dyntopo is great but there is a lot of situations where you cannot remesh your model every time you change it. + baking normal map from multires is faster + very accurate (maybe in future we will have baking AO or Cavity maps from multires, i hope).

For tests i used latest blender 2.82 beta build from Blender.org, blender-2.82-81b7f8efaf7a-windows64
I don't know why, but someone removed old level switch feature frob Multires. This how it was(in 06 month of 2.8 build) -


And now how it is -

I don't know who and why done this. Because bug is still in place, but no level switching anymore.... Why? Please, at least return this level switch to us.

In this thread -> https://developer.blender.org/T73047 devs. are trying to solve Multires. problem once and for all that why devs have made the decision of removing the ability to switch between multires levels.

Sergey Sharybin (sergey) closed this task as Resolved.Mar 13 2020, 2:33 PM

Apply Base, Subdivide and Reshape should now be fixed (rBbc0a0cdf171).

Sure, there are always corner cases of any algorithm, so if there are still issues place submit separate report with exact meshwhich causes the issue attached.

So far we did some tests here at the studio and artists were happy!

DO WANT this in the nignt-build
Is simething wrong with it? Because it is still not in master.

DO WANT this in the nignt-build
Is simething wrong with it? Because it is still not in master.

When can we expect a new build with the functionality from Blender 2.79/2.80
Are there any nightly builds that incorporate this?