Page MenuHome

Hair dynamics do not update when the number of hairs are increased unless hair is baked.
Closed, ArchivedPublic

Description

System Information
Operating system:
Microsoft Windows 10 Home

Graphics card:
Intel(R) HD Graphics 630

NVIDIA GeForce GTX 1060

Blender Version
Broken:
2.80 (sub 35), branch: blender2.8, commit date: 2018-11-30 22:29, hash: 0f5b53ba4dc, type: Release

Worked: (optional)
2.79 (sub 6), branch: blender2.8, commit date: 2018-11-28 21:55, hash: fb057153b05, type: Release

Short description of error
Hair dynamics do not update an increase in hair particles.

Exact steps for others to reproduce the error
00 (click on empty area to clear splash screen)
01 Add new particle system to default cube.
02 Set particle system to Hair.
03 Set particle count to 50 to speed things up.
04 Enable hair dynamics.
05 Hit space bar to play animation and the hair falls as normal.
06 Double the hair particles from 50 to 100.
07 Hit space and only the old particles will react to dynamics.
08 Now bake the cache.
09 Hit space and all the hair particles are dynamic.
10 Free all bakes.
11 Hit space again and all the hair particles are still dynanic.

It does not matter if the animation is interrupted with an esc or allowed to go the whole 250 frames.

Based on the default startup or an attached .blend file (as simple as possible).
This blend file was saved just after step - 07 Hit space and only the old particles will react to dynamics.

Details

Type
Bug

Event Timeline

John Krumpotick (jskksj) renamed this task from Hair dynamics do not update when the number of hairs are increased unless to Hair dynamics do not update when the number of hairs are increased unless hair is baked..Dec 1 2018, 11:54 PM
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can seem to reproduce this on the latest blender beta. Can you retest and report back your results?

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.

Sorry about that, I missed your email. And yes the problem has been resolved.