Page MenuHome

animation with static hair particle system, single-frame render glitch
Closed, ResolvedPublic

Description

Operating system: Windows 8.1
Graphics card: Toshiba notebook, Intel core i7, AMD Radeon graphics chip
Broken: 2.79b release

Short description of error:

Final Rendering a 90-frame animation with a static hair particle system (sprinkles on a donut), from the Blender Guru Introduction Tutorial. Only the camera is moving, 2 keyframes on camera, no other keyframes on anything else. Blender correctly renders frames 0-21. Here is frame 21:

Frame 22 is rendered as though the donut with the pink icing has a different Seed for the particle generator.

Then frames 23-78 are rendered correctly. A similar problem occurs in frame 79, affecting the sprinkles on the other donut (chocolate icing). Then frames 80-90 are rendered correctly.

Here's a 3-second video, you can clearly see the two glitch frames 22 and 79.
https://www.dropbox.com/s/9yl4wtqdtokn4xw/donut_001.mp4?dl=0

Here are the files to reproduce the problem:
https://www.dropbox.com/s/a59qgichd5x6n8b/BlenderGuruTutorial011.blend?dl=0
https://www.dropbox.com/s/n2zl5velk5a9c28/ChristmasTreeJacked.jpg?dl=0
https://www.dropbox.com/s/0azhj2wbvb8vmq4/wood.jpg?dl=0
https://www.dropbox.com/s/aehfmfhbs5oqnyy/wood_normal.jpg?dl=0

Just render frames 21 and 22, and if the sprinkles on the pink donut don't match (as shown above), you've reproduced the bug. You could do the same thing with frames 78 and 79.

I note that the problem only seems to be in the Final Render. In the 3d Viewport Solid View, and the Rendered View, the static particle system seems to be correctly static across all frames.

Thank you,
Lloyd

Details

Type
Bug

Event Timeline

Here is the .blend file with all the image and normal files packed into it:
https://www.dropbox.com/s/mkcgdwj6ptj30cj/BlenderGuruTutorial012.blend?dl=0

I've tried rendering the animation using Blender 2.80 beta, and the bug is gone:
https://www.dropbox.com/s/8rcyp6d3dgeng4r/donut_002.mp4?dl=0
Sorry I didn't think of that sooner.

Sebastian Parborg (zeddb) closed this task as Resolved.Mon, Dec 10, 2:08 PM
Sebastian Parborg (zeddb) claimed this task.

You can also try out the latest 2.79 version from this page and see if it is solved in that one: https://builder.blender.org/download/

I'm closing this as resolved in the mean time. If it is not solved in the latest 2.79 version, let me know.

Thank you for the suggestion, Sebastian. I have tried using the latest 2.79 release (Date: 2018-12-09 20:48, Hash: d7ef1af22bf), as you suggested. Unfortunately, the problem is still there. Here is frame 21:


Here is frame 22:
With this version, the sprinkles on the chocolate donut jump from frame to frame.

So it appears that the bug is still present in the official 2.79b release and the most recent 2.79 experimental release, but fixed in the 2.80 Beta release.

@Brecht Van Lommel (brecht) I'm guessing I can keep this closed as it is solved in 2.8?

The random number seeding got big changes in 2.8, which solves this kind of issue, also changes rendering results. So I think we can keep this closed as it will be fixed in the next release, but we don't want to backport that fix.