Page MenuHome

Error: EXCEPTION_ACCESS_VIOLATION
Open, IncompletePublic

Description

System Information
Operating system: Windows 7 Ultimate x64
Graphics card: AMD Radeon RX 480

Blender Version
Broken: 2.79b, 2.78

Short description of error
Recently rebuilt my computer, new SSD, latest GPU driver, C++ libraries installed, every other program and games run just fine. Blender, however, starts and crashes within a few clicks or if opening/minimizing other windows. I've been googling solutions and trying them all night but to no avail.

Tried running most recent build both install and from zip. Tried running 2.78, both installed and from zip. Ran via administrator, no addons have been added, installed Python, halted anti-virus program, ran via CMD, replaced the version_update.py file, ran with the opengl32.dll file placed alongside the .exe and the program still crashed; basically any solution google handed to me I went through.

No matter which way I try to run blender it crashes and prints to CMD:

Error: EXCEPTION_ACCESS_VIOLATION

Exact steps for others to reproduce the error
Start blender, click anything or maximize any other program and click back to blender, and blender instantly closes.

Details

Type
Bug

Event Timeline

Not sure, how to handle such cases @Brecht Van Lommel (brecht)... Do we have debug builds for people to download to be able to get more information about where the crash happens?

Gabriel Giss (redbox) added a comment.EditedWed, Dec 5, 3:37 AM

Uneventful update; tried updating every optional Windows Hotfix, running Blender from a separate internal HDD, reinstalling the C++ libraries and Python, but same story. Amendment to the issue though that might help someone help me out here:

Blender works ONLY if I do not touch ANY other programs. Can't open Chrome, maximize Discord, open the User Prefs in Blender--because if any other window is brought to attention, Blender main window instantly closes. As well, if Blender is minimized it also instantly closes down. But if I run blender and don't do anything else, it works. This is obviously not viable.

Sorry if bumping my thread like this isn't allowed. I'll keep trying things as I think of them, but I'm kind of out of ideas at this point.

Ran the sfc /scannow function in CMD with no issues found, turned off "Data Execution Prevention" setting, booted with all other services turned off but the vital ones, ran all optional hotfixes and updates for my operating system, installed Blender thru Steam; tried running the zip of 2.76 since it supports OpenGL 1.2 instead, downgraded my GPU Driver to a year olds build; nothing works.

This computer--the cpu, mobo, gpu, os--all ran Blender fine a week ago. Now after changing to an SSD, literally everything else works just fine, every game, Photoshop, etc, just not Blender.

  • Try using the latest daily 2.79 builds if you haven't already:

https://builder.blender.org/download/

  • I've never used this myself so I can't vouch for it, but you could try using this utility to ensure graphics drivers are completely uninstalled before installing new ones. Sometimes traces from old drivers can interfere with the new ones, particularly related to CUDA and OpenCL.

https://www.wagnardsoft.com/

Brecht Van Lommel (brecht) triaged this task as Incomplete priority.Thu, Dec 6, 11:51 AM