Page MenuHome

2.80 refuses to complete startup to reach splash screen - always hangs grey with AMD graphics driver crash notice
Open, NormalPublic

Description

System Information
Operating system:
System:
Manufacture: ASUSTek COMPUTER INC
Model: ASUS Desktop PC CM1855 Series
Processor: AMD FX(tm)-8120 Eight-Core Processor
Installed Memory: 10.0 GB
System Type: 64-bit Operating System, x64-based processor

Graphics card:
Display adapter: AMD Radeon HD 7600 Series
Driver Provider: Advanced Micro Devices, Inc.
Driver Date: 2014-07-04
Driver Version: 13.251.9001.1001
Digital Signer: Microsoft Windows Hardware Compatability Publisher
Device status: "This device is working properly" (as of 2018-12-03)

Virtual Memory: Total paging file size for all drivers: 4000 MB (=admin setting; changeable)

Blender Version
2.80 Beta Windows 64 bit
Blender-2.80-a205493426b-win64.zip
Downloaded 2018-12-02 about midnight

Broken: Unknown

I have tried on four different occasions recently to download and install an experimental build for Blender 2.80, and it has not worked yet. I get the same instant notice shown as soon as I launch the program: "AMD graphics driver has stopped working; driver has successfully recovered". But Blender does not get to open the splash screen: it stays all greyed out and hangs indefinitely until I must close it down using Task Manager override to exit the program.

Worked: 2.80 = Negative ; My Blender 2.79b is working just fine!

Details

Type
Bug

Event Timeline

I can't say I'm certain, but I had problems like this on Linux with my AMD 290x sometime during summer this year. However after some new GPU driver updates this was resolved. I'm guessing that this is a driver problem.

If you can not find any newer drivers than the one you have from 2014, then if this is a bug with the drivers, there not much to do.

If you can't find any newer drivers (or if the problem still persists with newer) then you could try if it works when you run linux instead (as the open source drivers are still maintained for older GPUs)

Sebastian Parborg (zeddb) triaged this task as Normal priority.

If updating drivers or moving to a newer blender beta does not work, try starting blender with --debug-gpu or --debug-gpu-force-workarounds and report your results here.

Hi Sebastian:
I have downloaded todays' version of Blender 2.80 and run the two debug commands from the Command Prompt window: both times did not work for me. Here is the text readout after doing both times:

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Users\Curtis>cd /dC:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a789837-wi
ndows64

C:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a789837-windows64>blender.exe -
d --debug-gpu
Switching to fully guarded memory allocator.
Blender 2.80 (sub 35)
Build: 07/12/2018 17:54 Windows Release
argv[0] = blender.exe
argv[1] = -d
argv[2] = --debug-gpu
read file

Version 280 sub 24 date unknown hash unknown

Using OpenGL 4.3 debug facilities
GL application marker: Successfully hooked OpenGL debug callback.
found bundled python: C:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a789837-w
indows64\2.80\python
GL API deprecated behavior: glLineWidth uses wide lines (parameter <width> with
value '0x0') which are deprecated and do not work outside of the compatibility context

{End of report. Blender main screen opens but remains all greyed and just hangs "not responding" Closed by quitting Command Prompt window}

`````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Users\Curtis>cd/dC:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a789837-win
dows64

C:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a789837-windows64>blender.exe -
-debug-gpu-force-
found bundled python: C:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a789837-w
indows64\2.80\python
unknown argument, loading as file: --debug-gpu-force-
Error: Cannot read file 'C:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a78983
7-windows64\--debug-gpu-force-': No such file or directory
Error: argument has no '.blend' file extension, not using as new file, exiting!
C:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a789837-windows64\--debug-gpu-force-
Saved session recovery to 'C:\Users\Curtis\AppData\Local\Temp\quit.blend'

Blender quit

C:\Users\Curtis\Downloads\blender-2.80.0-git.0fe5a789837-windows64>

{Blender main screen flashed on and then instantly closed, after I hit Enter on the command prompt.}

````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````````

My System:
Running Windows 8.1 (copyright 2013 Microsoft)
ASUS Desktop PC CM1855 Series
AMD FX9tm)-8120 Eight-Core Processor
AMD Radeon HD 7600 Series Display adapter {I ran the update for this driver yesterday at the AMD website and it returned message that the driver as installed is current and up to date; no newer drivers available}
10.0GB installed memory
64-bit Operating System, x64-based processor
No Pen or Touch Input is available for this display

I hope above reports can help your developer team discover why Blender2.80 won't run. (I just tried my Blender 3.79b, which opens and runs just fine!?)

With my regards,
Curtis Walker

You missed the full debug argument. it's --debug-gpu-force-workarounds.

It seems that both windows 8.1 and windows 10 have more recent driver version. Maybe consider updating your Operating System.

Bon soir Clement:
I gathered all the Windows updates (as for as I know) for my computer tonight, installed them and restarted it; downloaded today's build blender-2.80.0-git.168a6a4bfc1-windows64, and tried again to open Blender 2.80: still hangs grey with blender.exe and AMD display driver has "stopped working; recovered successfully" and had to use Task Manager to End it again. I then ran the full Argument as stated: here is the Command Prompt report (i.e. Blender still would not load to splash screen, stays greyed out):

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.

C:\Users\Curtis>cd d/C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-wi
ndows64
The filename, directory name, or volume label syntax is incorrect.

C:\Users\Curtis>cd /dC:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-wi
ndows64

C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-windows64>blender.exe -
-debug-gpu -force-workarounds
Using OpenGL 4.3 debug facilities
GL application marker: Successfully hooked OpenGL debug callback.
found bundled python: C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-w
indows64\2.80\python
unknown argument, loading as file: -force-workarounds
Error: Cannot read file 'C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc
1-windows64\-force-workarounds': No such file or directory
Error: argument has no '.blend' file extension, not using as new file, exiting!
C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-windows64\-force-workar
ounds
Saved session recovery to 'C:\Users\Curtis\AppData\Local\Temp\quit.blend'

Blender quit

C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-windows64>

Perhaps I am still missing some important Windows updates, or else this AMD Display Driver I have installed on my computer will never be able to run Blender 2.8? Oh well, at least my Blender 2.79b runs fine!

C'est la Vie. Dans tous les cas, Merci Beaucoup pour tout votre très bon travail = Blender est Le Meilleur!!

I tried the Argument again, but without the space (oops); here's the report:

C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-windows64>blender.exe -
-debug-gpu-force-workarounds

GPU: Bypassing workaround detection.
GPU: OpenGL indentification strings
GPU: vendor: ATI Technologies Inc.
GPU: renderer: AMD Radeon HD 7600 Series
GPU: version: 4.3.12618 Core Profile Context 13.251.9001.1001

found bundled python: C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-w
indows64\2.80\python
GPUTexture: texture alloc failed. Not enough Video Memory.Error : EXCEPTION_AC
CESS_VIOLATION
Address : 0x00007FF6C8FDEE53
Module : C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-windows64\ble
nder.exe

C:\Users\Curtis\Downloads\blender-2.80.0-git.168a6a4bfc1-windows64>