Page MenuHome

Texture coordinate from another object seems does not work render/lookdev modes
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: nvidia gtx 1060

Blender Version
Broken: 2.80, a205493426b, blender2.8, 2018-12-03

Short description of error
Texture coordinate from another object seems does not work render/lookdev modes in eevee.
It works for cycles render mode, but not in cycles lookdev.

Exact steps for others to reproduce the error

  1. add a cube and a plain axis empty object
  2. for the cube, add noise texture to the color input of the shader
  3. add Texture coordinate node
  4. connect Object output to vector input of noise texture
  5. select the empty axis in the texture cordinate as object to follow
  6. move the cube or the axis in the viewport for eevee render or devlook modes, or in cycles devlook mode, nothing hapens. Only works in Cycles render mode.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.EditedDec 6 2018, 11:15 AM

I'm guessing this might be a dependency issue where the object location is not updated in the node setup.
@Sergey Sharybin (sergey), do you feel that is a task for Clement or is this in your area?

Philipp Oeser (lichtwerk) closed this task as Archived.Dec 6 2018, 11:33 AM
Philipp Oeser (lichtwerk) claimed this task.

This is a know limitation for now, listed here https://docs.blender.org/manual/en/dev/render/eevee/materials/nodes_support.html#other-nodes-support

quote:

Texture Coordinate Node: From Dupli and coordinate from custom Object is not supported.

Afraid we have to close for now...