Page MenuHome

Blender 2.8 hides RGB channels instead of Alpha channel
Closed, InvalidPublic

Description

System Information
Operating system: Ubuntu 18.04
Graphics card: Radeon RX 580

Blender Version
Broken: 2.8

Short description of error
An issue with both Cycles and EEVEE in Blender 2.8 beta. Whenever a .png image with transparency is used, Blender hides RGB channels instead of Alpha channel. UV editor seems to show transparency right, so the issue is in viewport and on rendered images.



Exact steps for others to reproduce the error
Render with Cycles or EEVEE

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

You are using the Mix Shader Node wrong.
The way this works is that when Fac is 1 blender will use the bottom socket (and when Fac is zero it will use the upper socket).
Just reversing the sockets fixes this, see:

Dont see a bug here, closing...