Page MenuHome

Clicking on Dope Sheet deselects all bones
Closed, ArchivedPublicKNOWN ISSUE

Description

Blender Version
Broken: blender-2.80.0-git.1b6a394d862-windows64
Worked: blender-2.79b

Short description of error
Selecting keyframes in Dope Sheet or clicking on area between them deselects all bones in the 3d viewport.
Clicking on keyframes in the Timeline editor works fine.

Exact steps for others to reproduce the error

  1. Open attached .blend file
  2. Click on Dope Sheet Editor with the mouse button that is assigned to selection
  3. Notice how all bones are deselected.

Event Timeline

Jurek (solartistic) added a comment.EditedDec 4 2018, 3:13 PM

I just noticed that when I check on "only selected" the bug doesn't occour.

Sebastian Parborg (zeddb) lowered the priority of this task from 90 to 50.

I've noticed that this also happens in 2.79 for me. So I'm unsure if this is intended or not.

I don't think it happens exactly like this in 2.79. There is selection syncing when you click on the channels, but not when you click on the keyframes as far as I can tell.

Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".

I can confirm the bug.
It worked in blender 2.79

@Germano Cavalcante (mano-wii) please remember to add the - it worked in 2.79 information in the original bug description. A fully triaged report should have all the required information to fix it in said description.

Sybren A. Stüvel (sybren) renamed this task from bug - Clicking on Dope Sheet deselects all bones to Clicking on Dope Sheet deselects all bones.Feb 24 2020, 10:36 AM
Sybren A. Stüvel (sybren) closed this task as Archived.
Sybren A. Stüvel (sybren) claimed this task.
Sybren A. Stüvel (sybren) changed the subtype of this task from "Bug" to "Known Issue".

The selection sync between bones and dope sheet is a known weak area of Blender, so I'm closing this as a known issue. Don't worry, I've added this to my list of weak areas of the animation system so that it's not forgotten.