Page MenuHome

Graphical glitch in Edit Mode: Vertices have hair-like extrusions (not to be confused with normals)
Closed, ResolvedPublic

Description

System Information
Operating system: macOS High Sierra version: 10.13.6 (Macbook Pro 2015)
Graphics card: Intel Iris Graphics 6100

Blender Version
Broken: Blender-2.80-1b6a394d862 (release date: Dec. 4th, 00:11:08)

Short description of error
A persistent graphical glitch in Edit Mode where there are hair-like extensions extruding from the vertices. Becomes longer/shorter when increasing/decreasing Vertex size in User Preferences. To clarify these are not the Normal lines.

Exact steps for others to reproduce the error
Simply open up most recent Blender 2.80 Beta build and go into edit mode. No other steps necessary.

Examples
Vertex size 4:

Vertex size 32:

Details

Type
Bug

Event Timeline

Vlitz (Vlitz) updated the task description. (Show Details)Dec 4 2018, 6:35 PM
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Dec 14 2018, 6:39 PM

Your test blender version is quite old, can you try a newer one from https://builder.blender.org/download/ ?

If that doesn't help, can you attach the output of "--debug-gpu" and try to run blender with "--debug-gpu-force-workarounds" and see if that helps.

Vlitz (Vlitz) added a comment.EditedDec 15 2018, 2:00 AM

{F5956880}At the time of posting, that was the latest version. I've been keeping up with the latest public builds, and didn't want to spam the same bug over and over. The problem unfortunately still exists. I've tried "--debug-gpu" and "--debug-gpu-force-workarounds" as requested in the latest build (blender-2.80-aca13040dac), and still the same thing persists. However, when running Blender through "--debug-gpu" in the terminal, an error message appears whenever I switch to Edit Mode in the Viewport. Not sure what it means as I don't really code, but I do suspect it has to do with the bug:

Warning: Pass : , Uniform 'viewportSize' not found!
Warning: Pass : , Uniform 'edgeScale' not found!

Also, I don't know if this will be helpful or not, but I've run the latest build in Windows 10 using Bootcamp and the problem wasn't there.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Normal.Dec 15 2018, 2:11 AM
Vlitz (Vlitz) closed this task as Resolved.Jan 24 2019, 5:16 AM

Just writing an update: it seems this particular bug has been fixed with the Jan. 24th release (7f77961f1c38). Will update if the bug pops up (hopefully not).