Page MenuHome

Segmentation faults while trying to render with GPU and CPU hybrid rendering in Cycles
Closed, ResolvedPublic

Description

System Information
Operating system: Linux Mint 19
Graphics card: nVidia GTX 970

Blender Version
Broken:
Blender 2.8 Hash: 26d5a3625ed
Worked: (optional)

While trying to render some scenes with Cycles, I have been getting a crash with segmentation fault as a reason while having GPU and CPU hybrid rendering active. In many cases the problem is solved by choosing CPU in the device type and then rendering.

Terminal message:
TIFFReadDirectory: Warning, Unknown field with tag 37724 (0x935c) encountered.
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Writing: /tmp/28Jem_rebuild.crash.txt
Segmentation fault (core dumped)

Crash report:

Blender 2.80 (sub 35), Commit date: 2018-11-29 15:57, Hash 26d5a3625ed

Tool 'Select Box' not found for space 'IMAGE_EDITOR'. # Warning
Tool 'Select Box' not found for space 'IMAGE_EDITOR'. # Warning

backtrace

./blender(BLI_system_backtrace+0x1d) [0x1b807ad]
./blender() [0x114e679]
/lib/x86_64-linux-gnu/libc.so.6(+0x3ef20) [0x7f5ff8f99f20]
./blender() [0x24d9447]
./blender() [0x2575196]
./blender(_ZN3ccl9CPUDevice13thread_renderERNS_10DeviceTaskE+0x14b8) [0x1eea478]
./blender(_ZN3ccl13TaskScheduler10thread_runEi+0x83) [0x2b368a3]
./blender(_ZN3ccl6thread3runEPv+0xe) [0x2b384de]
./blender() [0x63ad72f]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x76db) [0x7f5ffa5446db]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x3f) [0x7f5ff907c88f]

System options have the GTX 970 and CPU as compute devices, Cycles has GPU rendering active. Sample file may have CPU selected.


Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Jan 4 2019, 4:32 PM

I sadly do not have a CPU+GPU combo setup to test this.

Could you try a newer build in the off chance that this has been solved?

Brecht Van Lommel (brecht) closed this task as Resolved.Jan 4 2019, 4:36 PM
Brecht Van Lommel (brecht) claimed this task.

This was a temporary issue in the first beta build, it's been fixed since then.