Page MenuHome

Quick Edit from External Rollout in Paint Mode gives an error message
Closed, ResolvedPublic

Description

Operating system: Windows 10
Graphics card: Nvidia GeForce 1060 GTX

Broken: blender2.8, commit date: 2018-12-06 00:27, hash: 74db65e5424, type: Release
Worked: (optional)

When I try to export a snapshot preview for editing in an aplication like photoshop it gives the error "Operator bpy.ops.paint.image_from_view.poll() expected a view3d region". I may be doing something wrong, but in 2.79 I didn't got this message, worked like a charm; Here is the video explaining the issue:

Drop an object in the scene, go to paint mode; in the brush settings go to External rollout and press Quick Edit to send it to photoshop; returns an error message;

Cheers!

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.Dec 6 2018, 7:14 PM

This seems to be a remnant of when the toolbar were tied to the 3D view. The quick edit operation still expects that it should be called from the 3D view region.

Campbell Barton (campbellbarton) closed this task as Resolved.EditedMar 18 2019, 8:50 AM

This is a duplicate, it's since been worked around (uses largest 3D view). Although this should really use the 3D view still since its currently guessing.