Page MenuHome

transform orientation setting (pivot point) has no effect in 2.80
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 7
Graphics card: GTX 1060

Blender Version
Broken:
version: 2.80 (sub 35), branch: blender2.8, commit date: 2018-12-06 00:27, hash: 74db65e5424, type: Release

Worked:
2.79 release
version: 2.79 (sub 6), branch: master, commit date: 2018-12-04 15:03, hash: f63da3dcf59, type: Release

Short description of error
the transform orientation setting in 3d viewport is ignored by rotation/scale etc., rendering
the 3d cursor kinda useless (though add mesh still spawns the object correctly
at the 3d cursors position)

Exact steps for others to reproduce the error
start blender, place 3d cursor somewhere, switch pivot point to 3d cursor, try to rotate the cube
around the 3d cursor. in 2.79 (release and latest build) it does, in 2.80 it does not, instead it
rotates around its origin.

i started using blender 2.80 builds since mid october, and the bug is already present there.

cheers,
boogie

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Are you sure you are using the Pivot Point popup (as opposed to the Transform Orientation popup)?
[since 2.8 the 3d cursor has orientation as well so you can use it for that, however your description indicates you want to use it as a pivot?]

If I do that, I can happily rotate around the cursor:

Marking as incomplete for now, please comment again if that fixes it for you...

oops, sorry i mixed those two up. thank you for the clarification.
it works perfectly indeed.

Philipp Oeser (lichtwerk) closed this task as Resolved.Dec 6 2018, 3:16 PM
Philipp Oeser (lichtwerk) claimed this task.

OKi, closing then