Page MenuHome

Matcaps issue
Open, NormalPublic

Description

System Information
Operating system: Windows
Graphics card: ATI AMD Radeon HD 7560D

Blender Version
Broken: 2.80, be91d4ef957, blender2.8, 2018-12-04

Short description of error
Matcaps won't work, they display improperly (Usually coming up as green and dark rust orange) until X-Ray is turned on, then they display properly until X-Ray is turned back or set to 1.0

Exact steps for others to reproduce the error
Just start Blender 2.8, go to Shading, turn off outline, and you should see it. Set it to Matcap and try changing them, they all display the same as I described above, screenshot attached

Details

Type
Bug

Event Timeline

is a problem already known .. and for some gpu amd has already been solved ..
this is another amd gpu with the buggy drivers to add .. to the list ..

Well, I'm glad you guys are working on it -- Keep up the good work, Blender 2.8 is amazing and all of you should be very proud

I can not reproduce this on my AMD 290x running linux.

Because your GPU has been EOL (end of life) for a while now, no new drivers will be released for it on windows.

If you guys are feeling adventurous, maybe you could try out Linux and see if the problem still persists there? The drivers are still some what maintained in linux.
Be sure to take a recent linux distribution release though, as some AMD driver bugs were fixed during the summer that prevented blender 2.8 from functioning (for me at least).

@Levi (One-Eyed-Jack) Can you give us your system-info.txt?

@Germano Cavalcante (mano-wii) How do you propose to detect this gpu? driver version seems to be a bit extreme and maybe not reliable enough.

@Levi (One-Eyed-Jack), can you test again with the latest build?
If I'm not mistaken, the version you are using is prior to recent changes in the area.