Page MenuHome

Cycles Engine for Blender 2.80b crashes upon using GPU as render device, typical AMD driver problem?
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 Pro 64 bit Build 17134
Graphics card: Sapphire Nitro+ RX580 4GB model
CPU : A6-7400k
AMD Driver : Radeon Software Version 18.12.1

Blender Version
Broken: 2.80, edbf15d3c044, blender2.8, 2018-11-28

Short description of error
When changed the render engine to Cycles and try to render it with OpenCL, blender crashes. Using CPU to render does not seem to have this problem, but I still use a very weak CPU so i'd prefer to avoid using it for render preview if possible.

Exact steps for others to reproduce the error
-Default startup settings
-Open blender 2.80b
-Make sure OpenCL active
-Change render to Cycles
-Change device to GPU Compute
-Hit render button

Details

Type
Bug

Event Timeline

Alaska (Alaska) added a subscriber: Alaska (Alaska).

Just tested it with Blender 2.8 version 497a9ef7a39 on an RX 570 4GB with driver versions 18.12.1 on Windows 10 and I'm unable to recreate this issue.

Have you tried a clean install of the Radeon GPU drivers and updating your version of Blender?

Hello Alaska, thank you for responding to my problem first and foremost. And apologize I write the blender build wrong on the OP, i'm having trouble on Blender 2.80 Beta. But i'm glad you get the point.

Apparently it is indeed GPU driver issue, tried running a test render on the stable version of Blender 2.79b and it return the same problem. I tried to fresh installing the driver from the same version (18.12.1) and the problem is still there, so i proceed to downgrade the driver from 18.12.1 to 18.9.3, uninstall the newest driver completely and install this one, reboot, aaaaand it works again. Pretty weird since yesterday it worked just fine on Blender 2.79b, almost made me think 2.80 Beta is the culprit here. But everything is good to go now.

Thank you for your assistance!

Sebastian Parborg (zeddb) closed this task as Resolved.Fri, Dec 7, 11:01 AM
Sebastian Parborg (zeddb) claimed this task.

I'll mark this as resolved then