Page MenuHome

wireframe/orthographic/front/side/topview crash 2.8
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: gtx 1060 3gb

Blender Version
Broken: 2.8, blender-2.80-c1f6ecdfabf-win64
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error

blender crashes when in wireframe, front/side/topview and orthographic at the same time

Exact steps for others to reproduce the error

Go ino wireframe, go into front/side/topview and toggle orthographic.

Based on the default startup or an attached .blend file (as simple as possible).

I updated my Nvidia drivers to the current release and my Blender version was downloaded today.

Here's a Google drive Link to a video I made of the bug:

https://drive.google.com/file/d/192nEJAOfZkAYhrjNYuyxFnQ91gXZDv-H/view?usp=drivesdk

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Dec 7 2018, 6:37 PM

I can not reproduce this error. Can you try updating to the latest blender beta and additionally updating your GPU drivers to the latest version.

If none of these help, we can go from there.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Normal.Dec 7 2018, 8:11 PM

Can you post the output if you run blender with --debug-gpu
Additionally, can you try if --debug-gpu-force-workarounds makes any difference?

I just got the same bug, here is a super simple file that crashes consistently when you press 3 for left view on 6a5e8096973 win64

If you apply rotation on the object it will not crash anymore.

Sebastian Parborg (zeddb) raised the priority of this task from Normal to Confirmed, Medium.Dec 8 2018, 12:11 AM

Can you post the output if you run blender with --debug-gpu
Additionally, can you try if --debug-gpu-force-workarounds makes any difference?

I wasnt shure how to run it on debug mode, since im not a developer, but I googled and tried it. Not shure if it is what you wanted.
It would open the all gray starting window but not actually run blender.

C:\WINDOWS\system32>start /b "" "C:\Program Files\Blender Foundation\Blender 2.8\blender.exe" --debug-gpu

C:\WINDOWS\system32>Read prefs: C:\Users\Admin\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
Using OpenGL 4.3 debug facilities
GL application marker: Successfully hooked OpenGL debug callback.
found bundled python: C:\Program Files\Blender Foundation\Blender 2.8\2.80\python

https://drive.google.com/open?id=1wp5PisQBjIM4w-CWmnIwmvm92uxQes4O