Page MenuHome

Force field not affecting rigid body simulation
Closed, ResolvedPublic

Description

System Information
Operating system: Windoxs 10
Graphics card: GeForce GTX 1060

Blender Version
Broken: 2.80, 6a4e8096973, blender2.8, 2015-12-07 18.28
Worked: 2.79

Short description of error
Adding a force field to a rigid body simulation does not change anything.

Exact steps for others to reproduce the error

  • Quick rigid body setup with a sphere falling on a plane
  • Add a "Force" force field
  • Start the simulation

Details

Type
Bug

Event Timeline

Stephen Swaney (stiv) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Dec 8 2018, 4:37 PM

Please attach a .blend showing the problem.

Sorry about that, here is a file for 2.80:

And the same file working in 2.79:

Stephen Swaney (stiv) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Dec 8 2018, 4:53 PM

Thank you!

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Ok, I fixed part of this in 5cc015f0ad05.
However there's another regression. Changes to force fields don't mark the rigid body cache as outdated (the PTCACHE_OUTDATED flag needs to be set).
I don't think I have time to figure out how the depsgraph works to add the proper relations for that, so I think either @Sergey Sharybin (sergey) or @Bastien Montagne (mont29) should take a look.

I can not reproduce the issue, behavior seems to be the same in 2.79 and current master.
There was a of fixes done in the area, so probably got fixed as a part of another issue?

As I mentioned there is a second regression here, in that changes to the force field don't invalidate rigid body cache.
Simple way to reproduce:

  1. Add a rigid body.
  2. Add a force field.
  3. Simulate a few frames.
  4. Change force field strength and see that the rigid body cache hasn't been invalidated.
Lucas Boutrot (thornydre) closed this task as Resolved.Jun 26 2019, 1:27 PM

This task seems to be resolved

Definitely not resolved for me..
Adding force fields or changing their parameters don't trigger cache invalidation for rigid bodies.

Changing parameters works for particles and soft bodies, but adding new force fields don't.

If there are still issues make a new report, with all the requested information.

If there are still issues make a new report, with all the requested information.

There are already a couple merged into this one: T64493 and T59135
and also this one created yesterday: T66105

I was commenting here since @Sebastian Parborg (zeddb) seemed to have choosen this as the main task for the issue, I can open a new one if you want so though.

If your issue has already an open task there is no need to open a new one. But when a task is not fully resolved for you, or re-appeared, or anything like is totally worth opening a new task.

This helps keeping track of changes and fixes, saves time when we need to look in a history (we can easily get all relevant information from a task, without need to read an entire conversation trying to not miss any crucial detail).