Page MenuHome

Blender 2.8, lock camera to view in a copied scene
Closed, ArchivedPublic

Description

System Information
Windows 10
Graphics card: Nvidia GTX 1080

Blender Version
Broken: lock camera to view in a copied scene is manipulating the camera in the original scene rather than the new scene's camera
1fa527bfa3a, blender2.8, 2018-12-05

Problem: copied a scene using "Full Copy", the camera in the new scene is "Camera.001", I made sure it is the camera in the new scene, in 3D View, when I check "Lock Camera to View", trying to orbit the camera doesn't work, instead, "Camera" from the original scene is manipulated in the viewport

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can not reproduce this issue with a build from today.

Could you try a more recent build from https://builder.blender.org/download/ and see if the issue is this there?

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.

I am having this same issue in the official 2.8 release. I can't seem to reliably replicate it though.

I have a lot of cameras bound to markers, and in my "Main," scene the cameras switches between the different cameras and move around without difficulty. In my other scenes which were created using "Full Copy," it seems to be stuck on the first camera position, even if the camera moves from that position during the animation.

Other than the main project where I encountered this bug, I was able to re-create it once in a test scene with just a couple of markers and animated cameras, but haven't been able to do it since. I will keep trying tomorrow and see if I can figure out a reliable way to replicate it.