Page MenuHome

core dumped when opening the file
Closed, ResolvedPublic

Description

System Information
Operating system: Ubuntu Linux
Graphics card: GeForce GTX 970/PCIe/SSE2

Blender Version
Broken: 2.80 (sub 35), branch: blender2.8, commit date: 2018-12-07 20:19, hash: 0fe5a789837, type: Release

Short description of error
I wanted to test simple scene with particles in Blender 2.80. It was crushing randomly (usually when switching workspaces) but generally worked. Now it dumps a core file when I open the file.

Exact steps for others to reproduce the error
Just open given blend file.

Sorry for the .blend file size, but I can't fix it now.

snow_v03.crash.txt is empty.

On console I get:

Read blend: /data/snow_v03.blend
blender: tpp.c:84: __pthread_tpp_change_priority: Assertion `new_prio == -1 || (new_prio >= fifo_min_prio && new_prio <= fifo_max_prio)' failed.
Writing: /tmp/snow_v03.crash.txt
[1]    848 abort (core dumped)  ./blender

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Incomplete priority.Dec 9 2018, 9:00 PM
Bastien Montagne (mont29) edited projects, added BF Blender: 2.8; removed BF Blender.

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

Sorry, attached files disappeared someway.


Brecht Van Lommel (brecht) closed this task as Resolved.Wed, Jan 9, 7:14 PM
Brecht Van Lommel (brecht) claimed this task.

This appears to have been fixed since it was reported. I can confirm the crash in 0fe5a789837 but not in latest.