Page MenuHome

Quick Favorites: add support for operator/prop enums (e.g. "Set origin")
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows 10
Graphics card: Nvidia GTX1080

Blender Version
Broken: 2.80, 16fc62e15f0, blender2.8, 2018-12-12
Worked: 3d92afca7eb

Short description of error
The Set origin menu is not possible to put into quic favourites.

Exact steps for others to reproduce the error
3dView -> Object menu -> Right click on "Set origin..." -> empty menu.

Details

Type
To Do

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Confirmed, Medium priority.

Can confirm.

I see two problems here:

  • Right clicking on operator_menu_enum brings up an empty menu.
  • Right clicking on a menu entry while the menu is open, does not open the right-click-menu at all.
Philipp Oeser (lichtwerk) closed this task as Resolved.
Philipp Oeser (lichtwerk) claimed this task.

This seems to be fixed, no?

Havent hunted down the relating commit, but as of today I am getting the menu (and choosing the entry will add it to the favorites OK)

Closing (but feel free to comment again/reopen if issues persist...)

I thought it's about this menu, which does not seem to be fixed yet:

Ah, OK, will check on this, too...

Philipp Oeser (lichtwerk) renamed this task from Set origin command not possible to put in quick favourites to Quick Favorites: operator/prop enums (e.g. "Set origin") cannot be added.Jan 8 2019, 11:02 AM

As merged from a report I previously made was relating to a slightly different though closely related issue.

some screenshots;-

these are missing in 2019-01-11 - 1c7695b8483d and all previously downloaded versions.

Campbell Barton (campbellbarton) renamed this task from Quick Favorites: operator/prop enums (e.g. "Set origin") cannot be added to Quick Favorites: add support for operator/prop enums (e.g. "Set origin").
Campbell Barton (campbellbarton) lowered the priority of this task from Confirmed, Medium to Confirmed, Low.

Support for this can be added but this is more of a TODO, added to T63726: User Interface Module

Super sorry for adding yet another duplicate to this list. I did check for it but I guess not good enough.

Philipp Oeser (lichtwerk) raised the priority of this task from Confirmed, Low to Confirmed, Medium.Wed, Aug 7, 2:56 PM

I hear you, hope to get to it soon...