Page MenuHome

Viewport face orientation colours (non-overlay) appear to have been unified
Closed, InvalidPublic

Description

System Information:
CPU: Ryzen 5 2600
GPU: RX 570 4GB
OS: Windows 10 Home

Blender Version:
Broken: Blender 2.8 7d4d9e9dbd3

Short description of error:
In the viewport the colour difference between the front face and back face appears to have entirely disappeared.

A scene with both a back face and front face in view in 7d4d9e9dbd3:


The same scene in 4c31bed6b46 from the 30th of Novemeber:


Is this intentional or a bug?

Event Timeline

Alaska (Alaska) renamed this task from Normals are hard to see by colour to Face orientation colours appear to have disappeared ).Dec 13 2018, 12:16 PM
Alaska (Alaska) renamed this task from Face orientation colours appear to have disappeared ) to Face orientation colours appear to have disappeared.
Alaska (Alaska) created this task.
Alaska (Alaska) renamed this task from Face orientation colours appear to have disappeared to Viewport face orientation colours (non-overlay) appear to have been unified.Dec 13 2018, 12:23 PM

Afaik this is intentional. If you want to see if your normals are inverted, use Overlays > Face Orientation.

William Reynish (billreynish) changed the task status from Unknown Status to Unknown Status.Dec 13 2018, 2:45 PM

@Clément Foucault (fclem): I'm marking this as archived now, and I presume this is intentional, as it's nicer in most cases to be able to see your model without normal orientation display errors we had before.

We have Overlays > Face Orientation for checking normal orientation.

This comment was removed by Alaska (Alaska).

@William Reynish (billreynish)

I agree with you, it does look nicer, I just find the old face orientation colours more useful. For example, I applied a sub-division surface modifier to my mesh and some of the faces were acting a bit weird. I put this down to possibly bad topology because none of the faces were that dark grey colour. I spent a couple minutes trying to fix the topolgy and gave up. I then opened the same file in an older 2.8 build to see if a certain bug was in that one and that's when I found my face orientation was pretty much random on the object.

I personally believe the old face orientation colours in the viewport should be left in as most hobbyists won't have face normals in mind when modeling a mesh and thus will probably forget about it when experiencing similar issues to the one I had. If the colours were changed to the way they were, they would see the colour difference and probably quickly realize the issue.

Even if the colours aren't changed back by default, I would love to see an option in the user preferences to change it back or at least an option in the themes to change the colours of the face orientation overlay.


Edit: It also helps in situations like this:

The old way was essentially a limitation of the old drawing code, which is now fixed in 2.8.

Often times you may create shapes out of planes, or non-manifold geometry. 2.7x behaviour made these types of objects hard or impossible to deal with, because they would look completely wrong when viewed from angles where the normal points away.

If the face orientation colors are not themble, they should be. Then you could set them to whatever you like, to only show a warning color when the normal points away.

@William Reynish (billreynish)

As far as I can tell, the face orientation colours are not themeable. Are you able to add a proposal for the addition of this feature? (as far as I can tell non-developers can't make proposals.)

This was removed essentially because of performance reason and also because it look would be way worse with the new shading.

There is cases where you want it to show backfaces when modeling but sometimes not (like when working with two sided geometry).

There is real technical limitation here we can solve this pretty easily. It's just a matter of design.

@Clément Foucault (fclem): IMO we already have a solution in the Face Orientation. If users could theme these colors, there would be no issue I think.

There is cases where you want it to show backfaces when modeling but sometimes not (like when working with two sided geometry).

The problem is that working with two sided geometry is specific and rare.
The ability to control the orientation of the faces is necessary throughout the entire process of almost any complex modeling.
That means, that without proper default face orientation shading we are forced to live in that specific Face Orientation mode for almost everything we do in Blender.

Open someones scene - face normal check, all those thousands imports from different software - thousands face normal checks, because exporters doesnot make it correctly, any single topology change - face normal check, otherwise modifiers and tools go mad, combining scene - face normal check, export something somewhere - face normal check, setting up render - face normal check, start final render - face normal check, got some doubts - face normal check, because if you forgot to make face normal check, you will be forced to render everything once again.

Here's what work in Blender looks like now.

Patch is applied and it works.
This task should be tagged as Closed:Resolved now.
https://developer.blender.org/D6262