Page MenuHome

file become unsupported by 2.79 after making some change in 2.80. render is not correct
Open, Needs Information from UserPublic

Description

System Information
Operating system:8.1
Graphics card:

Blender Version
Broken:
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
i create a file from in blender 2.79 and open it in 2.80 and make some lighting adjustment for rendering. then i notice the render is not as render produced in 2.79. simply it just avoids all the holes like thing in blender 2.80 render on cycles. then i save that file. then go to 79 it didn't open

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
create blender file in 2.79 that is actually blender motion graphics tutorial's cube tutorial.
i render with the 2.79 it seems pity nice
but it took more time in render so go for blender 2.80.
i change some lighting values for rendering eevee then it seems so pain without any holes.
then try to do this on cycles.
there is no noticeable change in render other than increase in render time
then try to continue on the 2.79 but it didn't open at all
then try to link the files for blender file. that also results in unsuccessful.

i attach the blender file and render on cycles on 2.80 and physics file,cache file{F5942298}

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.Dec 13 2018, 3:43 PM

Could you be a bit more specific what you mean by "it just avoids all the holes like thing in blender 2.80"? A screenshot in 2.79 and 2.80 would help.

Also I'm unsure what the bug here is? Are objects missing in the render, are the render times different, is the lighting different, ...?

i dont know what option to choose for posting this on post.
the problem is i add 2 objects in screen. cube and cylinder. cube as dynamic paint canvas, cylinder as dynamic paint brush.
i use cloud texture with cell noise data base as the texture to displace it by displace modifier.
now the cylinder and cube coinsering area should be removed on the cube by the mask modifier.
that produce holes on cube
but the holes is avoided in blender 2.80 just render as simple cube with wire frame modifier added.

FYI, 2.79 is not compatible with files saved by 2.80, and eevee is a 2.80-only feature.

i had seen the some blender file of film hero that is fully compatible only with eevee. if i open on the 2.79 it shows the nothing but the file is open with empty screen because that greease pencil tool can run only in eevee. but in my case the the screen didnt open at all.
jut blender crashes everytime when i open it

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jan 15 2019, 11:49 AM

that "mask modifier" issue needs to be looked at again

Should be put back to Needs Information from User imo! Or just closed as invalid because it's really unclear what bug is actually being reported. I just spent quite a while trying to untangle that mystery:

Eevee lights' "Energy" and Cycles lights' "Strength" values are not connected in any way, so if you want to adjust a light in both Eevee and Cycles, you'll have to do it twice.

I don't know for sure if this is a bug or a design choice, but this is the only thing in the post and thread that seems like an actual bug, although it is only briefly mentioned in half a sentence as sort of a side note. @Arunachaleshwaran (arunachalam) can you confirm that this is your main issue?

Also note:

  1. 2.8 file not opening in 2.7 is not a bug.
  2. If your render is slower, you should submit a separate bug report with a file that is compatible with 2.7 so that we can test it. But first, you should make sure you're using the same compute device (CPU/GPU) on both 2.7 and 2.8.
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Mon, Feb 11, 4:50 PM