Page MenuHome

Cycles render flickers black while "Text Info" is disabled
Closed, ResolvedPublic

Description

System Information:
CPU: Ryzen 5 2600
GPU: RX 570 4GB
OS: Windows 10 Home

Blender Version:
Broken: Blender 2.8 Beta f13a4b2f123

Short description of error:
Cycles veiwport flickers to black while another 3D viewport is open and the overlay "Text Info" and "Gizmo" is disabled (This is basically an explanation of what causes T58506)

Exact steps for others to reproduce the error:

  1. Open the default "General" startup file.
  2. Change your render engine to Cycles and change viewport samples to 0.
  3. Split the 3D viewport so you have atleast two 3D viewports.
  4. In one 3D viewport enter Cycles rendered mode. I will now be giving the viewport numbers.

  1. In viewport 2 disable overlays (or disable "Text Info" and "Gizmo" in the overlay's drop down).
  2. Now interact with viewport 2 (Rotate around an object, pan around the scene, play an animation, select objects, etc)
  3. Notice that when ever you do something in viewport 2, viewport 1 flickers. This only occurs while:
    1. Viewport 2 has the "Text Info" and "Gizmo" (specifically the "navigate" Gizmo) overlay disabled and while viewport 1 is still drawing samples in Cycles (and is hence why I recommended changing the preview samples to 0).

Event Timeline

Alaska (Alaska) renamed this task from Cycles render flickers black while to Cycles render flickers black while "Text Info" is disabled.
Alaska (Alaska) updated the task description. (Show Details)
Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.