Page MenuHome

Make Single User Crashes Blender
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GeForce 1080

Blender Version
Broken:
2.8 Beta 2018-12-14
Hash: f13a4b2f123

Short description of error

Making a linked object a single user crashes blender.

Open the attached scene. There's a duplicate of the default cube. Both objects have been linked.

Select the object at the origin. Go to the Object menu, choose Relations > MNake Single User > Object & Data. Blender will crash.

Details

Type
Bug

Event Timeline

Forgot to add that this only crashes if you choose "Selected Object" when prompted by Blender.

Sebastian Parborg (zeddb) closed this task as Resolved.Dec 14 2018, 4:32 PM
Sebastian Parborg (zeddb) claimed this task.

I can reproduce the issue on your specific commit. However on a later one c1adf86a2ef30a9033ff7cfe757b1e7c7b174784 this seems to be solved as I can't reproduce it anymore.

You can try it out when a newer build arrives. However I'll mark this as solved now as I can reproduce this anymore with newer commits.