Page MenuHome

Parts of a mesh select even if the cursor is far away from them
Closed, InvalidPublic

Description

System Information
Operating system:
Kubuntu 18.04 LTS, x64 (nvidia-driver-390)
Graphics card:
NVIDIA GeForce GTX 1080

Blender Version
Broken:
2.80, 81ea815dcb6, blender2.8, 2018-12-13,

Description of error
Parts of a mesh select even if the cursor is far away from them, and this leads to unpleasant consequences.
See video:
https://youtu.be/SPqN-KhQjN0

Details

Type
Bug

Event Timeline

Leonid (ljonya) updated the task description. (Show Details)
Sebastian Parborg (zeddb) closed this task as Invalid.
Sebastian Parborg (zeddb) claimed this task.

This is the case in 2.79 also. I think this is intended.

@Brecht Van Lommel (brecht) anything to add?

It's indeed intentional that the mouse cursor does not have to be exactly in the right place, that lets you work faster without having to precisely position the cursor.

Unless this bug report is about some specific issues with mixed vertex and edge selection, or another regression compared to 2.79? I can't tell from the video.

Leonid (ljonya) added a comment.EditedDec 14 2018, 8:36 PM

@Brecht Van Lommel (brecht) But when I want to deselect all, clicking in an empty space, without seeing it, I select new parts of the mesh. With version 2.79 such problems are not possible, but since 2.80 they are constant. In addition, I can not control what will be selected: edge or vertex.