Page MenuHome

Rigid body
Closed, ResolvedPublic

Description

System Information

OS: Ubuntu 18.04 bionic
Kernel: x86_64 Linux 4.16.8-041608-generic
CPU: Intel Core i7-8700 @ 12x 4.6GHz
Graphics card: Integrated Mesa DRI Intel(R) HD Graphics (Coffeelake 3x8 GT2)

Blender Version
Broken: 2.80 Beta, d40bffa17f6, 2018-12-06

Short description of error

physic no working properly, or crash blender (if no floor)

Exact steps for others to reproduce the error

  • apply Rigid body Type Active to the Cube
  • add Array modifier (off or on doenst matter)
  • start animation

-> it either crash Blender or bring the cube directly to the floor (if you have put one)

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Dec 17 2018, 11:17 AM

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

System Information

OS: Ubuntu 18.04 bionic
Kernel: x86_64 Linux 4.16.8-041608-generic
CPU: Intel Core i7-8700 @ 12x 4.6GHz
Graphics card: Integrated Mesa DRI Intel(R) HD Graphics (Coffeelake 3x8 GT2)

Blender Version

Broken: 2.80 Beta, d46d8e831ce, 2018-12-18

Short description of error

physic no working properly

Exact steps for others to reproduce the error

  • from the default Blender scene
  • apply Rigid body type Active to the Cube
  • move the Cube up, to the Z Axis
  • add an array modifier to the Cube. leave default option.
  • create a Plane with Rigid body Type Passive
  • play the animation

-> the Cube falls directly to the floor

this blend file has been created following those instruction.

while the simulation didnt work at first, after closing Blender and opening this file, the simulation seems to work at first. but something is weird. the cube doesnt bounce on the floor.

from this Blend file if you:

  • delete the plane / floor
  • play the animation

-> the Cube falls directly to the floor. a floor that has been deleted.

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jan 15 2019, 12:07 PM
Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.Wed, Jan 23, 4:54 PM

I can reproduce this issue if I follow the steps above. If I open the attached file and make the animation play, it seems to work. But if I then remove the plane. The cube teleports to the plane location and starts falling from there.
On the next try the cube just vanishes when the animation starts.

I think this bug has just been fixed by @Sergey Sharybin (sergey) today. I can't reproduce this bug in today's master following the steps described.

Ulysse Martin (youle) closed this task as Resolved.Tue, Feb 12, 5:13 PM

I change the status to resolved. Tell me if I do something wrong

Yes. i confirm. the bug has been corrected from today's built.