Page MenuHome

Gizmo selction issues Mac OSX High Sierra and Hardops
Closed, ArchivedPublic

Description

System Information
Operating system: High Sierra
Graphics card: 570

Blender Version
Broken:

(blender2.8, 2018-12-16)
Worked: (Not sure if this worked on previous builds.

Short description of error
Symmetry gizmo unselectable / flashing on mouse over.
video of the issue https://www.youtube.com/watch?v=lLN_dq1umT4

Exact steps for others to reproduce the error
Just create any shape, move the origin to something else than default and voila. ALT+X symmetry gizmos become unresponsive. Everything else works.

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Needs Information from User priority.

Is this gizmo part of Hardops?

If yes, please report the bug the developers of the addon first. They can make a bug report here if appropriate. In any case the bug report should be independent of HardOps.

Unless I understand it wrong the issue is not hard ops related as on windows 10 there’s no problem with the add on. It’s just something hard ops calls for to appear on screen that is broken in Mac version of blender.
Again, same add on file installed on windows works without issues.

ok, in that case it would still be helpful to be able to reproduce the bug without HardOps. We can't really fix something we cannot reproduce.

Paul (PixelFixer) added a comment.EditedDec 18 2018, 3:03 AM

I think I managed to successfully recreate the bug. I'm not sure it can be tested without the add on BUT:

Every time the translate tool gizmo is visible the symmetry gizmo from the add on goes nuts.

WHEN I click on the select tool (space / b) and the transform gizmo disappears then the symmetry ons work well.

Overlay of some sort pretty much. Hope that helps to kill the bug or at least give you guys idea what to put in docs for developers to watch or something.

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

Just updated the post to include Windows Platform.
Same behavior on Windows 10. Just tested.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

As you can't reproduce this without the addon, can you contact the hardops devs and ask them to create a small test example for us that doesn't rely on having the addon?

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

It's a bug in an add-on that we do not maintain, so it's up to the author of that add-on to fix. The bug being platform specific does not mean it is a bug on the Blender side.

We don't need to keep a bug report open for that. If someone can identify a bug in Blender it can be reported, but investigating what might go wrong with external add-ons is just not something we have time for or can reasonably track.