Page MenuHome

win32: Save/Load Window State!
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 1809 17763.194

Blender Version
Broken: 2.80 Beta, 9149e894210, blender2.8, 2018-12-16

Short description of error
The window size and state is not saved on Windows 10.

Exact steps for others to reproduce the error
Open Blender and maximise the window. Close Blender. Re-open Blender. The window is not maximised.

This is still a problem in 2.79 also.

Details

Type
Bug

Event Timeline

Campbell Barton (campbellbarton) renamed this task from Save/Load Window State! to win32: Save/Load Window State!.

This has been like this since forever..
The only way I could make it work is to save the startup file (File -> Save Startup File) with the window maximized.

Yes that works for me too on both 2.79 and 2.8. Why isn't it set up like this by default? This was brought up by Campbell Barton (https://developer.blender.org/p/campbellbarton/) in a previous task but nothing seemed to be done about it. https://developer.blender.org/rBSd6a6f285d6b1983d2cf823e81570ad03dbc5bf06. I hope it gets fixed this time.

Campbell Barton (campbellbarton) closed this task as Invalid.

You need to save the startup for window state to be restored on next start, closing.