Page MenuHome

Blender 2.8 2018-12-04 19:42 crash with smoke sim
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Titan X Pascal

Blender Version
Broken:
(2.8 Beta release)
(2.80, be012c88c52, blender2.8, 2018-12-04, as found on the splash screen)
Worked: (optional)

Short description of error

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Blender crashes when simulating smoke after checking "high resolution" with cycles enabled as viewport renderer. The crash occurs when moving the playhead to the begginning of the frame range in order to play back the simulation.

Details

Type
Bug

Event Timeline

Cannot reproduce here.

Tried opening the file, enable "High Resolution", switched to viewport render, moved to frame 1, pressed play to start animation --> still no crash...

Please make sure that the viewport render is set to Cycles with CPU compute. I though originally that I was set to GPU compute but I was mistaken, and as it turns out when GPU is enabled it doesn't crash. It is only a problem with CPU compute. I am using a AMD Ryzen Threadripper 1950X. With 64gb of DDR4 333Mhz.

ADDITIONAL INFORMATION: I was wrong again. GPU works better and crashes less often but it still crashes after playing around a little bit with playback and settings.

Increasing resolution divisions seems to crash it. At 32 GPU seems to be able to handle it okay with fewer crashes. but switching to 64 crashes it every time.

Seems to be working under Linux with CPU.
Can you try a newer build?

If I change the settings and start playing back the simulation while in solid display view things seem to play back fine if I switch to cycles afterwards. It seems that the crashes only occur consistently while altering the resolution settings of the sim while in cycles preview.

I'll try a newer build.

It still happens in the latest Windows x64 build (12-18-2018) but it seems to be only when I change any of the settings while Cycles is enabled then try to scrub the timeline or jump to the first frame. It seems like I don't have as many issues if I change the settings in solid view then switch to cycles after playing through the sim once.

I've seen this crash as well, and was about to report it when I found this issue. I am on macOS, and just rebuilt Blender 2.8. It's really hard to consistently reproduce at the same point, but it does happen somewhere in the steps I was doing:

  1. Use quick smoke on the default cube
  2. Change emitter to fire and smoke
  3. Change to rendered view, and to Cycles
  4. Scale up the domain along z
  5. Move forward a few frames <The smoke visually gets messed up here after the scaling>
  6. Check high resolution <I think I once got a crash here>
  7. Go to frame one <may crash here>
  8. Go forward a frame <blender completely locks up>

It's almost always related to moving in the timeline. The crash is pretty quick, but if it locks up, it lasts for minutes before I gave up and killed it. Some steps may be optional; it's inconsistent in crashing as it is.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Jan 23 2019, 5:29 PM

I can't reproduce this on my end. Is this still and issue with a build from today?

Brecht Van Lommel (brecht) closed this task as Archived.Mar 1 2019, 4:49 AM
Brecht Van Lommel (brecht) claimed this task.

Following bug tracker policy, closing report after 7 days due to insufficient information to investigate further. We can reopen the report if more information is provided.