Page MenuHome

Weird Sub-division results when used in conjunction with creases
Closed, ResolvedPublic

Description

System Information:
CPU: Ryzen 5 2600
GPU: RX 570 4GB
OS: Windows 10 Home

Blender Version:
Broken: Blender 2.8 Beta c4ee77cde8b0

Short description of error:
Some weird snapping issues occur in Blender 2.8 with creases and the sub-division modifier that didn't occur in Blender 2.79.

Exact steps for others to reproduce the error:
Versions shown: Blender 2.8 Beta c4ee77cde8b0 & Blender 2.79

Details

Type
Bug

Event Timeline

Jacques Lucke (JacquesLucke) triaged this task as Confirmed, Medium priority.Dec 20 2018, 12:25 PM

Increasing the quality of subdivisions to 6 solves it.
If the performance does not get much worse I think that the quality parameter should always be at the maximum, or even be eliminated.

Increasing the quality of subdivisions to 6 solves it.
If the performance does not get much worse I think that the quality parameter should always be at the maximum, or even be eliminated.

Not entirely, the plane still experiences issues at quality level 6.

Sergey Sharybin (sergey) closed this task as Resolved.Jan 22 2019, 3:38 PM

The behavior on the cube is not a bug. Sharper creases requires deeper mesh analysis, which happens when you increase quality. And as the tooltip suggests, higher quality means slower analysis, so we can't have it set to maximum level by default.

The issue with crease on plane is solved in rBa8902ab49ad.

To thanks for the report, but all parts which we consider bug are solved.