Page MenuHome

"Assigned" Vertex Group Has Extra Faces When "Selected"
Closed, InvalidPublic

Description

System Information
Windows 10 Home (1803)
NVIDIA GeForce GTX 1070

Blender Version
Broken: 2.80, e79bb957fc3, 2018-12-08

Short description of error
Looks to me like a vertex group with one unselected face in between two selected faces fills in the unselected one when you click the "Select" button.

NOTE: I don't know what the hell I'm doing, so I put the little details that may not matter in parenthesis for a quicker read and organization.... lol.

Exact steps for others to reproduce the error

  1. (I did load factory settings)
  2. (Delete default objects)
  3. Create a UV Sphere
  4. (Give it smooth shading)
  5. Enter edit mode, select faces (with "ctrl click" and in a line that creates a kind of hook or letter J pattern) with some faces between unselected and push the "Assign" button
  6. Deselect the faces in the group (I used Alt A)

7 Click on "Select" button in vert groups to re-select assigned faces

  1. Result = the faces between the selected faces are now also selected.

Thank you for your time, Hope I didn't waste it, I'm new to all this.
-John

PS, sorry about the wonky upload technique.....

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

Well, if you use vertex groups, then the vertices are taken into account.
And since all vertices are actually assigned to that vertex group (by having their surrounding faces selected), all of them will get selected (which also makes the face appear selected).

Not a bug here. Note you can use Face Maps instead (these are for faces specifically)

Closing (but feel free to comment again if issues persist)