Page MenuHome

UV unwrap: Pinning is broken
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 64bits
Graphics card: Geforce 1070

Blender Version
Broken:
2.80, 7d8f57e0c013

Description
Pinning vertices on any mesh in the UV editor is not functioning. Unwrapping after pinning leads to vertices displacing and deforming.

Exact steps for others to reproduce the error
Unwrap the default cube and pin any number of vertices and unwrap again.

Revisions and Commits

Event Timeline

Brecht Van Lommel (brecht) lowered the priority of this task from 90 to 50.
Jim Conrad (j-conrad) changed the task status from Resolved to Unknown Status.Jul 25 2019, 12:51 AM

System Information
Operating system: Windows 10 64bits
Graphics card: Geforce GTX 1080

Blender Version
Broken:
2.80, Release Candidate 1 & 2

Description
Pinning vertices on any mesh in the UV editor is not functioning. Unwrapping after pinning leads to vertices displacing and deforming.

Exact steps for others to reproduce the error

I'm seeing it somewhat intermittently but it's definitely reproducible. Seems to depend on the mesh itself. I'd encourage trying on more than just the default cube. Including my .blend file where I see it every time on the currently selected mesh.

Brecht Van Lommel (brecht) changed the task status from Unknown Status to Resolved.EditedJul 25 2019, 12:54 AM

Please don't reopen old tasks, create a new bug report, after 6 months it's unlikely to be the same issue.

Sorry for the confusion.