Page MenuHome

Crash: Render Animation
Closed, ResolvedPublic

Description

System Information
Operating system: windows 10
Graphics card: 2x GTX 1080ti

Blender Version
Broken: 2.8 Beta, a91886e763bd

Short description of error
Blender crashed each time I try to render the animation. (Ctrl F12) Sometimes it crashes imediately, other times it crashes after frame 2 or 3 has rendered. I've tried disabling the compositor, making all of the files local on my machine, and switching output image type. It still crashes consistently.

Here is a link to the entire project folder: https://drive.google.com/file/d/1ywDUpCvy4P3NpG__Zdw3cD6EcTA4ZHuP/view?usp=sharing

Exact steps for others to reproduce the error

  • Open the .blend file
  • press Ctrl f12 to render.
  • Blender crashes after the first 1 or 2 frames render.

Just a note, the proper blend file can be found within the folder "scenes & 3D Assets and is called "E300_sculpt_smooth.blend"

Event Timeline

This comment was removed by Riley Brown (RileyBrown).

Confirmed on b49699b1ec6d. Here's my traceback:

blender.exe!animsys_evaluate_fcurves(Depsgraph * depsgraph, PointerRNA * ptr, ListBase * list, float ctime) Line 1708
	at c:\blender-git-2.80\blender\source\blender\blenkernel\intern\anim_sys.c(1708)
blender.exe!animsys_evaluate_action_ex(Depsgraph * depsgraph, PointerRNA * ptr, bAction * act, float ctime) Line 1841
	at c:\blender-git-2.80\blender\source\blender\blenkernel\intern\anim_sys.c(1841)
blender.exe!BKE_animsys_evaluate_animdata(Depsgraph * depsgraph, Scene * scene, ID * id, AnimData * adt, float ctime, short recalc) Line 2873
	at c:\blender-git-2.80\blender\source\blender\blenkernel\intern\anim_sys.c(2873)
blender.exe!BKE_animsys_evaluate_all_animation(Main * main, Depsgraph * depsgraph, Scene * scene, float ctime) Line 2984
	at c:\blender-git-2.80\blender\source\blender\blenkernel\intern\anim_sys.c(2984)
blender.exe!do_render_all_options(Render * re) Line 1642
	at c:\blender-git-2.80\blender\source\blender\render\intern\source\pipeline.c(1642)
blender.exe!RE_BlenderAnim(Render * re, Main * bmain, Scene * scene, ViewLayer * single_layer, Object * camera_override, int sfra, int efra, int tfra) Line 2531
	at c:\blender-git-2.80\blender\source\blender\render\intern\source\pipeline.c(2531)
blender.exe!render_startjob(void * rjv, short * stop, short * do_update, float * progress) Line 620
	at c:\blender-git-2.80\blender\source\blender\editors\render\render_internal.c(620)
blender.exe!do_job_thread(void * job_v) Line 339
	at c:\blender-git-2.80\blender\source\blender\windowmanager\intern\wm_jobs.c(339)
blender.exe!tslot_thread_start(void * tslot_p) Line 260
	at c:\blender-git-2.80\blender\source\blender\blenlib\intern\threads.c(260)
[External Code]
Benjamin Humpherys (brhumphe) triaged this task as Confirmed, Medium priority.Dec 20 2018, 9:52 PM

Other things worth noting:

  • This only happens on cycles, not eevee.
  • Despite the error being somewhere in the animation system, playback in regular viewport is just fine, even in rendered mode.
Benjamin Humpherys (brhumphe) raised the priority of this task from Confirmed, Medium to Needs Triage by Developer.Dec 20 2018, 10:01 PM
Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.

Backtrace:

Thread 69 "blender" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffcc7ff700 (LWP 10906)]
0x0000555557e3c60b in animsys_evaluate_fcurves (depsgraph=0x0, ptr=0x7fffcc7fd250, list=0x7fffcc821da0, ctime=4)
    at /home/zed/programmering/blender_master/blender/source/blender/blenkernel/intern/anim_sys.c:1708
1708			if ((fcu->grp != NULL) && (fcu->grp->flag & AGRP_MUTED)) {
(gdb) bt
#0  0x0000555557e3c60b in animsys_evaluate_fcurves (depsgraph=0x0, ptr=0x7fffcc7fd250, list=0x7fffcc821da0, ctime=4)
    at /home/zed/programmering/blender_master/blender/source/blender/blenkernel/intern/anim_sys.c:1708
#1  0x0000555557e3ca35 in animsys_evaluate_action_ex (depsgraph=0x0, ptr=0x7fffcc7fd250, act=0x7fffcc821d08, ctime=4)
    at /home/zed/programmering/blender_master/blender/source/blender/blenkernel/intern/anim_sys.c:1840
#2  0x0000555557e3eb09 in BKE_animsys_evaluate_animdata (depsgraph=0x0, scene=0x7fffd2a81008, id=0x7fffcca8e548, adt=0x7fffcc828868, ctime=4, recalc=2)
    at /home/zed/programmering/blender_master/blender/source/blender/blenkernel/intern/anim_sys.c:2870
#3  0x0000555557e3f18c in BKE_animsys_evaluate_all_animation (main=0x7fffd479ce08, depsgraph=0x0, scene=0x7fffd2a81008, ctime=4)
    at /home/zed/programmering/blender_master/blender/source/blender/blenkernel/intern/anim_sys.c:2984
#4  0x000055555773d940 in do_render_all_options (re=0x7fffcdbd4008)
    at /home/zed/programmering/blender_master/blender/source/blender/render/intern/source/pipeline.c:1640
#5  0x0000555557740958 in RE_BlenderAnim (re=0x7fffcdbd4008, bmain=0x7fffd479ce08, scene=0x7fffd2a81008, single_layer=0x0, camera_override=0x0, sfra=1,
    efra=120, tfra=1) at /home/zed/programmering/blender_master/blender/source/blender/render/intern/source/pipeline.c:2530
#6  0x000055555763a603 in render_startjob (rjv=0x7fffd48d4c08, stop=0x7fffd47d197c, do_update=0x7fffd47d197a, progress=0x7fffd47d1980)
    at /home/zed/programmering/blender_master/blender/source/blender/editors/render/render_internal.c:620
#7  0x00005555570618d9 in do_job_thread (job_v=0x7fffd47d1908)
    at /home/zed/programmering/blender_master/blender/source/blender/windowmanager/intern/wm_jobs.c:338
#8  0x00005555583ebe88 in tslot_thread_start (tslot_p=0x7fffd2919108)
    at /home/zed/programmering/blender_master/blender/source/blender/blenlib/intern/threads.c:259
#9  0x00007ffff63753c3 in start_thread () from /lib64/libpthread.so.0
#10 0x00007ffff4651edf in clone () from /lib64/libc.so.6

@Sergey Sharybin (sergey) don't know if you are the right person for this as the depsgraph stuff seems to not be used (set to NULL). So feel free to reassign

@Riley Brown (RileyBrown), In the future please attach a single file which demonstrates the issue. Linking the whole project is not helpful, just means we'll be spending more time isolating the issue. This also allows to attach file directly here, so it's always available in cases we need to look into this issue in 10 years (yes, we do time to time look into 10 years old reports, to ensure our new designs don't break something).

@Sebastian Parborg (zeddb), nowadays it's Brecht who is more familiar with the pipeline. But i'll have a look anyway.

Eh, was meant to also upload file here. Here it is

Thanks for the pro tip @Sergey Sharybin (sergey). I'll make sure to do that next time. Thanks for all of your work everyone.