Page MenuHome

Bug on EnvironmentTexture
Closed, ResolvedPublicBUG

Description

System Information
Operating system: windows 10 64
Graphics card: AMD radeon

Blender Version
Broken: 2.80
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28,

Short description of error

when i apply environment texture in world settings and the choose any image of any size (200 KB - 7 MB) and then the bug starts when i rotate with mouse my model got copied over and over in background texture(world texture) and it happened every time

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

go to rendered view by clicking Z
step 1 add any mesh object
step 2 got to world settings chose use nodes
step 3 choose glossy surface
step 4 in color select environment texture and choose any image and rotate view

Revisions and Commits

Event Timeline

System Information
Operating system: windows 10 64
Graphics card: AMD radeon

Blender Version
Broken: 2.80
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28,

Short description of error

when i apply environment texture in world settings and the choose any image of any size (200 KB - 7 MB) and then the bug starts when i rotate with mouse my model got copied over and over in background texture(world texture) and it happened every time

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

go to rendered view by clicking Z
step 1 add any mesh object
step 2 got to world settings chose use nodes
step 3 choose glossy surface
step 4 in color select environment texture and choose any image and rotate view

Benjamin (51423benam) lowered the priority of this task from 90 to 50.Dec 22 2018, 11:43 AM

I can confirm with the 2.8 build 'a91886e76ebd'.

Brecht Van Lommel (brecht) raised the priority of this task from 50 to 90.Dec 24 2018, 12:04 AM

@Benjamin (51423benam), "Confirmed" means a developer can reproduce the issue.

@Brecht Van Lommel (brecht) Ok sorry. But isn't that a big distraction for the devs if they have to do all the triaging on their own? Could one help there externally?

Well, you generally get artworks :-) if you don't use the background shader:

should be disabled here against abuse as in the node editor:

@Benjamin (51423benam), you can help by verifying if you can reproduce the issue, asking for more information if something is unclear, etc.

Just setting the priority is for developers, since that is also usually the time when it gets assigned to a specific developer, and means we know we don't need more information from the user.

Brecht Van Lommel (brecht) lowered the priority of this task from 90 to Normal.

You should not use BSDFs in the background, that will not work. I leave it up to @Clément Foucault (fclem) to decide if it should fail more gracefully (just show black I guess), or if the current result is ok.

@Brecht Van Lommel (brecht) I think we should disable the shaders the user isn't supposed to use, like @Martin Capitanio (capnm) suggested.

Germano Cavalcante (mano-wii) triaged this task as Low priority.Jan 17 2020, 5:06 PM

Although this is a bug (glitch), it is not that serious.
What should we expect by setting a Translucent BSDF in a World Output?
It could be marked as a Known Issue.

Clément Foucault (fclem) raised the priority of this task from Low to Normal.
Clément Foucault (fclem) changed the subtype of this task from "Report" to "Bug".