Page MenuHome

Blender VSE slow rendering
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Nvidia GTX 1050ti

Blender Version
Broken: 2.80 2018-12-20
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
All videos that I have edited through the blender VSE in the Blender 2.8 beta for 2018-12-20 have had twice the amount of render time as in Blender 2.79b

Exact steps for others to reproduce the error
Change the render engine to cycles, use the hybrid CPU and GPU render option, then render edited video from the default video editing layout.

Details

Type
Bug

Event Timeline

Richard Antalik (ISS) claimed this task.

Is this for preview or render(export) speed?

I was looking for bottleneck of preview speed (files from 2.79) and found, that hiding timeline(sequencer) doubles the max speed.
No code responsible for slowdown was identified however.
Often (not always) when I add timeline back, speed stay at higher rate.

Also new startup file has some color magic set up, so that also impacts performance.

But sure this is our issue, tagging this.

sorry it took this long to respond, i can try to hide the sequencer and see if that works, also do you no how to set the colors back to normal?

ok, i got it, i just created a save file from blender 2.79, if you know a better way though please tell me

Also please look at this thread and check if it applies to your problem.
tl;dr disable V-sync for blender in nvidia control center

Sebastian Parborg (zeddb) triaged this task as Confirmed, Medium priority.Jan 24 2019, 12:10 PM

@Richard Antalik (ISS) so I can mark this as confirmed then?

Oh I forgot to link to bug report in earlier comment.
Also T56755 looks similar to this.

I will triage this as described (I will try, as my reading / comprehending skill seems to be quite bad), then confirm / close based on actual cause of slowdown, if there is any.

To be sure about _exact_ numbers I did a comparison between 2.79 and 2.80:

Input: PNG 1920x1080
Output: H.264 AVI 1000 frames

2.79 default startup file: 2:15
2.80 default startup file: 6:00
2.80 without color transformation: 2:00

Slower render is caused by use of color transformations
Enabled is look: Base Contrast
Also shouldn't GLSL be default display method in VSE? AFAIK it is designed to be fast preview method.

Is there a reason for these items to default to current values?

Ok So Brecht said, that this(default settings) will be dealt with.
He also said, that look Base Contrast should not affect the output, which seems to be correct. So it was assumed, that no transformation is taking place. However this seems to not be correct and either transformation with unity coefficient is executed, or imbuf is converted to float, or something else is going on.

Either way:
Default look should be None, not any other no-op as user may not know what any of those items do, except none.

Richard Antalik (ISS) closed this task as Resolved.Mon, Apr 29, 3:28 AM

Defaults are now correct (no transform), in "Video editing" template. Maybe in others also - did not check.

General template is still set to Filmic. I believe, that this confused me few times, so I kept this task open as I thought those settings are consistent..