Page MenuHome

The SHIFT key, mapped on my graphic tablet is not working in Blender 2.80
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows 10
Graphics card: NVidia GeForce GTX 1070

Blender Version
Broken: 2.80 25-12-2018
(example: 2.79b release)
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error

I own a Huion NEW 1060 PLUS 8192 graphics tablet. One of my keys is mapped as SHIFT, but Blender doesn't recognize it at all. As one of the pen keys is mapped as the Middle Mouse Button.
Another key on the tablet is mapped as CTRL, another as ALT etc. and they all work with the MMB on the pen, but the SHIFT key is not recognizable to Blender. I can zoom, I can rotate, I can change views but i cannot pan nor select multiple objects. Basically, everything that is connected to the SHIFT key is dead.
Blender recognizes the keyboard SHIFT key, as well as a mapped SHIFT shortcut on the mouse, but not on the tablet.
All around the OS and in Rhino, Photoshop, Illustrator, the Shift key from my tablet is working perfectly, but inside Blender no.

Oh, and this is the first time I'm trying 2.8.
Everything works fine in 2.79.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Details

Event Timeline

Version 26.12.18 - Shift key is still dead on the tablet.

i have made a fix in the code of blender, but since my knowledge is limited i might have not understood some of the magic that was done with the shift buttons.
https://developer.blender.org/T59882

here is a build i made yesterday, maybe you can give it a try and let me know if the fix works for you as well.
name

i added the diff as a revision, i hope that is how this should be done? otherwise please let me know so i can do it correct in the future.

Brecht Van Lommel (brecht) triaged this task as Confirmed, Medium priority.Dec 27 2018, 11:56 AM
Toshe Andonov (ANDhitecture) closed this task as Resolved.EditedDec 28 2018, 12:21 AM
Toshe Andonov (ANDhitecture) claimed this task.

i have made a fix in the code of blender, but since my knowledge is limited i might have not understood some of the magic that was done with the shift buttons.
https://developer.blender.org/T59882
here is a build i made yesterday, maybe you can give it a try and let me know if the fix works for you as well.
name

i added the diff as a revision, i hope that is how this should be done? otherwise please let me know so i can do it correct in the future.

Yes! This is the fix. Blend it! :)

I don't know if I should've done that = Close - Resolved. Correct me if I did something I shouldn't have.

dan grauer (kromar) added a comment.EditedJan 1 2019, 4:26 PM

@Toshe Andonov (ANDhitecture) its not really fixed, it just shifts the functionality from one to the other, with this change we lose the shift+numpad functionality which is not good.
I will try to do a proper fix so both is working but it will take me some time due to my inexperience. i think this should stay open for the time since the issue has not been fixed.

I didn't notice that, but yes. I just checked it.
I'm still using 2.79 primarily. But I'm hoping that all of my "work stopping" issues will be resolved sooner, so I can transfer to the beta completely.

i have made a fix in the code of blender, but since my knowledge is limited i might have not understood some of the magic that was done with the shift buttons.
https://developer.blender.org/T59882
here is a build i made yesterday, maybe you can give it a try and let me know if the fix works for you as well.
name

Hey guys, can any of you teach me how to do this?