Page MenuHome

clicking material panel crashes blender giving a segfault
Closed, ArchivedPublic

Description

System Information
Operating system: 18.04.1 LTS
Graphics card:Radeon HD 8600M series

Blender Version
Broken:2.80, 60b930af3e73, 2018-12-25

Worked: 2.79

As far as I have realized, sapling addon only works in 2.79

Exact steps for others to reproduce the error

  • Open new blender scene in 2.80
  • add tree via sapling addon
  • show leaves
  • add material to the leaves
  • In my case, I added a principled BSDF, mixed with transparent BSDF, with a greyscale noise texture.
  • Now, bring out the UV Image Editor (CRASH IS IN THIS STEP)

When I look at the terminal, there's nothing much but a Segmentation fault.

Details

Type
Bug

Event Timeline

beez zaen (beez) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Cannot reproduce here.

Changing to UV Editing workspace doesnt crash in this file:

@beez zaen (beez): does this crash for you?
Could you share a blendfile that is saved right before bringing up the UV Editor (and that is crashing)?

Marking as incomplete until information is given...

This comment was removed by beez zaen (beez).

It had crashed before even with the noise texture, but it seems it absolutely does crash all the time, when you use an image texture or multiple image textures with complex connections. I've produced a screencast and attached the .blend file showing the crash:


In the attached .blend, I've saved the material but deleted the tree. The material is saved to a fake datablock. However, the textures were from cgtextures.com, so, I was unsure to pack them with the .blend. The textures were all of 2K resolution and had a diffuse texture, alpha texture for transparency, normal map, roughness map and translucency map, which all go into the principled BSDF.

BELOW IS THE SCREENCAST:

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Cannot reproduce either.

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.