Page MenuHome

Render Preview disappears
Closed, ArchivedPublic

Description

System Information
Operating system: Microsoft Windows 7 Ultimate, Version 6.1.7601, Service Pack 1, Build 7601
GPU: ASUS Strix Radeon Vega 64
CPU: Intel(R) Core(TM) i7-5960X
RAM: 32.0 GB
Full System Information: Here
Blender Version

Broken:
2.80, 29 December, 01:07:02 -7c438e5366b2-

Worked:
2.79

Short description of error

When rendering a video in the VSE the preview window goes blank upon interaction.

Exact steps for others to reproduce the error

  • Render Animation
  • Interact with render preview

Details

Type
Bug

Event Timeline

Richard Antalik (ISS) triaged this task as Confirmed, Medium priority.

I have noticed, that when you create new file from video editing template, render result is shown in new window, sequencer drawing code is not executed.

I think, that updating sequencer preview can be useful, but I don't know, what was the intention. Blame is heavily segmented..

Richard Antalik (ISS) closed this task as Archived.Jun 2 2019, 12:26 AM

I remember this working in 2.79.

However once again I looked at history in code, and this should be the same behavior for 10 years or so.
Checked once again in 2.79, sequencer preview goes blank.

In any case, this is by design - thread safety.