Page MenuHome

Blender 2.8 "No compatible GPUs found"
Closed, ArchivedPublic

Description

System Information
Operating system: Linux (Manjaro)
Graphics card: GeForce GTX 1050 Ti (with latest driver installed)

Blender Version
Broken:
Blender 2.8.0, d96596de294e, 2018-12-30, as found on the splash screen
Worked: (optional)
Blender 2.79b, 32432d91bbe, 2018-05-26, as found on the splash screen

Short description of error
When I open Blender 2.8 and go to preferences I get this message: "No compatible GPUs found" (see screenshot).


In Blender 2.79 my graphics card is detected:

Exact steps for others to reproduce the error
Based on the default startup, go to Preferences, System: General tab.

Details

Type
Bug

Event Timeline

LazyDodo (LazyDodo) triaged this task as Needs Information from User priority.

Are these builds from builder.blender.org or homebuild/distro build?

Jana Weigel (janexx) added a comment.EditedDec 30 2018, 8:20 PM

I have downloaded and build Blender 2.8.0 from here: https://aur.archlinux.org/packages/blender-2.8-git/

The 2.79 one is from Manjaro repository, installed with pacman.

please try with a build from builder.blender.org, just to rule out a distro specific packaging issue.

I tried this before but just got an error massage in terminal when I tried to start the application. Now I downloaded and started Blender 2.8 again from builder.blender.org and the problem is solved. I even can start now the previous downloaded and unpacked 2.8er version and see all GPUs. I don't understand it, but nevertheless thank you for your help!

LazyDodo (LazyDodo) closed this task as Archived.Dec 30 2018, 9:38 PM
LazyDodo (LazyDodo) claimed this task.

Same problem with the new update of Blender (31 december)
I have tried the version of the 25 october and it's good, but with the last versions (new preferences interface) it doesn't work !!!

Different issue, for mac opencl support has been dropped

I also have Manjaro, but downloading from builder doesn't help.
Should I open new issue? I've got AMD GPU (Radeon RX470). It worked before, I see significant loss of performance.

Got the same issue with GTX 1050, windows 7, and the latest GPU driver, is there any news?