Page MenuHome

FBX: out of image wrapping
Open, Needs Triage by DeveloperPublic

Description

OS: Win10 Edu (x64)
GPU: Asus Radeon RX-550 4Gb

Blender Version is: 2.79 f4dc9f9d68b from Steam

Well, I want to create the map from the game (Vice City), which uses Renderware Game Engine. I found the exact add-on to Import & Export. As you know, there a lot of "*.dff" files, so I had to write the script, which did it for me all the work. So, after the few minutes script stops on one file. I tried to format it without scripts, but there's still an error. There's console output of error:

Traceback (most recent call last):
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\__init__.py", line 620, in execute
    return export_fbx_bin.save(self, context, **keywords)
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\export_fbx_bin.py", line 3087, in save
    ret = save_single(operator, context.scene, filepath, **kwargs_mod)
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\export_fbx_bin.py", line 2994, in save_single
    fbx_objects_elements(root, scene_data)
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\export_fbx_bin.py", line 2793, in fbx_objects_elements
    fbx_data_mesh_elements(objects, me_obj, scene_data, done_meshes)
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\export_fbx_bin.py", line 1106, in fbx_data_mesh_elements
    elem_data_single_int32_array(lay_uv, b"UVIndex", (uv2idx[uv] for uv in _uvtuples_gen(t_luv)))
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\fbx_utils.py", line 499, in elem_data_single_int32_array
    return _elem_data_single(elem, name, value, "add_int32_array")
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\fbx_utils.py", line 446, in _elem_data_single
    getattr(sub_elem, func_name)(value)
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\encode_bin.py", line 161, in add_int32_array
    data = array.array(data_types.ARRAY_INT32, data)
  File "S:\SteamLibrary\steamapps\common\Blender\2.79\scripts\addons\io_scene_fbx\export_fbx_bin.py", line 1106, in <genexpr>
    elem_data_single_int32_array(lay_uv, b"UVIndex", (uv2idx[uv] for uv in _uvtuples_gen(t_luv)))
KeyError: (nan, nan)

location: <unknown location>:-1

Btw, when I starting Blender, console says this (not really sure, that the problem is here):

fake_module: addon missing 'bl_info' gives bad performance!: 'S:\\SteamLibrary\\steamapps\\common\\Blender\\2.79\\scripts\\addons\\convert_dff.py'
fake_module: addon missing 'bl_info' gives bad performance!: 'S:\\SteamLibrary\\steamapps\\common\\Blender\\2.79\\scripts\\addons\\utils.py'

So, here a the steps:

  1. Install the Add-on;
  2. Import this file:

;

  1. Try to export to FBX or any other format;

Here's the project file if you're unable to install add-on:

~~~~~
UPDATE
~~~~~
After I removed UV maps, everything goes normal. Guess, baking should solve something in my case.

~~~~~
UPDATE 2
~~~~~
I watched into the error and saw that UV wrap is outside of the image. This prevent model to be exported (see image above):

Details

Type
Bug

Event Timeline

Temirlan Tauzhanov (tauzhanovt) renamed this task from From DFF to any other format export error (-1) to UV map problem export.
Temirlan Tauzhanov (tauzhanovt) edited projects, added Import/Export; removed Addons.
Temirlan Tauzhanov (tauzhanovt) renamed this task from UV map problem export to out of image wrapping.
Adam Preisler (Alphisto) closed this task as Archived.
Adam Preisler (Alphisto) claimed this task.

Hi there is indeed something wrong with the UV map but after recreating it (and even moving it out of bounds) everything seems to be fine. Odd thing was that the center of transformation for UVs was somewhere in infinite lower-bottom part of the UV map space when you selected with B. But if you singularly clicked out all triangles and scaled the transformation center was where expected to be. There was no triangle hidden in lower left part, I was checking.

With 2.8 coming up and this being such an isolated issue I am archiving this.

Brecht Van Lommel (brecht) reopened this task as Open.

We should not close reports just because we don't know how to recreate the issue.

Glad to hear someone replied. I had to remove the original UV and rewrap it to solve my problem.

We should not close reports just because we don't know how to recreate the issue.

Well, I wrote "how-to" up there.

Glad to hear someone replied. I had to remove the original UV and rewrap it to solve my problem.

I just had to redo the UV map in place.

@Brecht Van Lommel (brecht) I think this is something to do with the fact that the model has been imported from dff. Feel free to investigate but to me this looks like a very isolated issue that most possibly arised from the dff importer that was written for Blender 2.62 therefore I closed this.

If you open the UV map editor, press A to select all and then S to scale you can see that the center of transformation is somewhere in infinity around bottom-left quadrant.

@Adam Preisler (Alphisto)

If you open the UV map editor, press A to select all and then S to scale you can see that the center of transformation is somewhere in infinity around bottom-left quadrant.

Yeah. That my screenshot above tells the same thing.

Brendon Murphy (meta-androcto) renamed this task from out of image wrapping to FBX: out of image wrapping.May 26 2019, 5:37 AM