Page MenuHome

Blender 2.80 HDRI contrast problem in cycles mode
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: EVga Nvidia 1080ti

Blender Version
Broken: 2.80 Beta
Not sure if a bug, but I have never encountered using HDRi in Cycle modes. The HDri colors are off. Tried to put 2.8 file to 2.79 (thought it might not happen anyways. But tried) to fix, or see. But, 2.79 exits.
(example: 2.80, edbf15d3c044, blender2.8, 2018-11-28, as found on the splash screen)
Worked: Played with options, made worse, had to use defaults. Problem still exists.

Short description of error
No error messages.
Exact steps for others to reproduce the error

Details

Type
Bug

Event Timeline

can you provide a blend file with the hdr packed in it?

Here ya go. With HDRi.

Not entirely sure how to set up your file but if I load your HDRI in a new blend file it works correctly:

William Reynish (billreynish) closed this task as Invalid.EditedJan 2 2019, 6:15 PM

Found the issue in your blend. You have enabled extreme light clamping by setting the clamp to 0.1:

This is not a bug, but user error.

Ah...sigh. I used clamping in past to help with the dotty effects. Thank you so much. Was worried.

Just FYI, Direct light clamping you should almost never use, or at least set it to something very high. Indirect clamping is more useful for getting rid of noise and can better be used a lower values - though 0.1 is very very low.

When I made this image (november). I used about 10.00 indirect and direct. Can see blotchy on wall, and grainy. Was really fustrated. I did a HDRi for back ground. Can see ontop fireplace a light is going through mesh. When I first started this, their was no lights going through with HDRis (that have street lights). And then.......Below.

I used 0.10 for direct and indirect. I was amazed, but still frustrated with light going through mesh. Can not figure out how, where. Like I have to redo. Furthermore, when I show others, they have trouble seeing. Had problems with lamps as well. Their is not enough tutorials explaining. Indirect, and direct. I tried to find, though the famous Blender Guru would have it. But nope. Explains a little bit, but not enough. I have to figure out myself.

And here is 0.00 for direct and indirect. I get those FireFlys (windows, wall, floor, roof). I still get confused about direct and indirect, futhermore denoising. Thanks for the problem. For one I thought it was my system, or preferences were off, or other.