Page MenuHome

Blender 2.8 Sequencer bug
Closed, ResolvedPublic

Description

System Information
Operating system: Widnows
Graphics card: NVidia GeForce GTX 1050 Version 399.24

Blender Version
Broken:
2.80, 4dd0a90f4213, blender 2.8, 2019-1 - 1

When I pressed add in the sequencer I got only the option of scene which had nothing within it.

I have no clue how to reproduce it, it is built into my blender version.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

In Blender 2.8, you can only other scenes to the sequencer, not the same scene. So, this menu will always be empty unless you have multiple scenes.

I am sorry but I don't quite understand what you mean by this.

Having the ability to use the same scene stirp in the same scene was problimatic (see T52586).
You can add a scene strip that didn't originate in the same scene you are using the VSE in (you can add a new scene in the top right of Blender).

Having the ability to use the same scene stirp in the same scene was problimatic (see T52586).
You can add a scene strip that didn't originate in the same scene you are using the VSE in (you can add a new scene in the top right of Blender).

@Christopher Anderssarian (Christopher_Anderssarian) But the problem is that nothing else is displaying, like sound etc when I hover over add.

Here is the image proof, look near the top of the screen.

Ahh... I see I believe @Brecht Van Lommel (brecht) and I have confused is for another commonly reported issue.


I can reproduce.

@Brecht Van Lommel (brecht) Mind having another look and please add the Video Sequencer tag.

Brecht Van Lommel (brecht) closed this task as Resolved.Jan 2 2019, 8:30 PM

That was fixed in rBe6d0d04dc32c: UI: correct sequencer icon in add menu, and will be solved in tomorrow's build.

Looks like it can't find the icon "CLIP", I'm not sure but maybe it can be related to this commit :
https://developer.blender.org/rB27619d727187e6d5624837d792fe0f2311a04464

This is what I got in the console... and probably this break other stuff as well...

BKE_icon_get: Internal error, no icon for icon ID: 780
BKE_icon_get: Internal error, no icon for icon ID: 787
BKE_icon_get: Internal error, no icon for icon ID: 793
BKE_icon_get: Internal error, no icon for icon ID: 796
BKE_icon_get: Internal error, no icon for icon ID: 805
BKE_icon_get: Internal error, no icon for icon ID: 811
BKE_icon_get: Internal error, no icon for icon ID: 812
BKE_icon_get: Internal error, no icon for icon ID: 813
BKE_icon_get: Internal error, no icon for icon ID: 814
BKE_icon_get: Internal error, no icon for icon ID: 815
BKE_icon_get: Internal error, no icon for icon ID: 816
BKE_icon_get: Internal error, no icon for icon ID: 817
BKE_icon_get: Internal error, no icon for icon ID: 818
BKE_icon_get: Internal error, no icon for icon ID: 819
BKE_icon_get: Internal error, no icon for icon ID: 820
BKE_icon_get: Internal error, no icon for icon ID: 821
BKE_icon_get: Internal error, no icon for icon ID: 822
BKE_icon_get: Internal error, no icon for icon ID: 823
BKE_icon_get: Internal error, no icon for icon ID: 824
BKE_icon_get: Internal error, no icon for icon ID: 825
BKE_icon_get: Internal error, no icon for icon ID: 826
BKE_icon_get: Internal error, no icon for icon ID: 827
BKE_icon_get: Internal error, no icon for icon ID: 828
BKE_icon_get: Internal error, no icon for icon ID: 829
BKE_icon_get: Internal error, no icon for icon ID: 830
BKE_icon_get: Internal error, no icon for icon ID: 831
BKE_icon_get: Internal error, no icon for icon ID: 832
BKE_icon_get: Internal error, no icon for icon ID: 833
BKE_icon_get: Internal error, no icon for icon ID: 834
BKE_icon_get: Internal error, no icon for icon ID: 835
BKE_icon_get: Internal error, no icon for icon ID: 852
BKE_icon_get: Internal error, no icon for icon ID: 934
BKE_icon_get: Internal error, no icon for icon ID: 935
Traceback (most recent call last):
  File "/home/sozap/APPS/blender/blender/2.80/scripts/modules/bpy_types.py", line 740, in draw_ls
    func(self, context)
  File "/home/sozap/APPS/blender/blender/2.80/scripts/startup/bl_ui/space_sequencer.py", line 335, in draw
    layout.menu("SEQUENCER_MT_add_empty", text="Clip", icon='CLIP')
TypeError: UILayout.menu(): error with keyword argument "icon" -  enum "CLIP" not found in ('NONE', 'QUESTION', 'ERROR', 'CANCEL', 'TRIA_RIGHT', 'TRIA_DOWN', 'TRIA_LEFT', 'TRIA_UP', 'ARROW_LEFTRIGHT', 'PLUS', 'DISCLOSURE_TRI_RIGHT', 'DISCLOSURE_TRI_DOWN', 'RADIOBUT_OFF', 'RADIOBUT_ON', 'MENU_PANEL', 'BLENDER', 'GRIP', 'DOT', 'COLLAPSEMENU', 'X', 'DUPLICATE', 'NODE', 'NODE_SEL', 'WINDOW', 'WORKSPACE', 'RIGHTARROW_THIN', 'BORDERMOVE', 'VIEWZOOM', 'ADD', 'REMOVE', 'PANEL_CLOSE', 'COPY_ID', 'EYEDROPPER', 'AUTO', 'CHECKBOX_DEHLT', 'CHECKBOX_HLT', 'UNLOCKED', 'LOCKED', 'UNPINNED', 'PINNED', 'SCREEN_BACK', 'RIGHTARROW', 'DOWNARROW_HLT', 'PLUGIN', 'HELP', 'GHOST_ENABLED', 'COLOR', 'UNLINKED', 'LINKED', 'HAND', 'ZOOM_ALL', 'ZOOM_SELECTED', 'ZOOM_PREVIOUS', 'ZOOM_IN', 'ZOOM_OUT', 'DRIVER_DISTANCE', 'DRIVER_ROTATIONAL_DIFFERENCE', 'DRIVER_TRANSFORM', 'FREEZE', 'STYLUS_PRESSURE', 'GHOST_DISABLED', 'FILE_NEW', 'FILE_TICK', 'QUIT', 'URL', 'RECOVER_LAST', 'THREE_DOTS', 'FULLSCREEN_ENTER', 'FULLSCREEN_EXIT', 'LIGHT', 'MATERIAL', 'TEXTURE', 'ANIM', 'WORLD', 'SCENE', 'OUTPUT', 'SCRIPT', 'PARTICLES', 'PHYSICS', 'SPEAKER', 'TOOL_SETTINGS', 'SHADERFX', 'MODIFIER', 'BLANK1', 'FAKE_USER_OFF', 'FAKE_USER_ON', 'VIEW3D', 'GRAPH', 'OUTLINER', 'PROPERTIES', 'FILEBROWSER', 'IMAGE', 'INFO', 'SEQUENCE', 'TEXT', 'SOUND', 'ACTION', 'NLA', 'PREFERENCES', 'TIME', 'NODETREE', 'CONSOLE', 'TRACKER', 'ASSET_MANAGER', 'NODE_COMPOSITING', 'NODE_TEXTURE', 'NODE_MATERIAL', 'UV', 'OBJECT_DATAMODE', 'EDITMODE_HLT', 'UV_DATA', 'VPAINT_HLT', 'TPAINT_HLT', 'WPAINT_HLT', 'SCULPTMODE_HLT', 'POSE_HLT',....