Page MenuHome

2.80 32-bit appears broken (on 64-bit Windows at least)
Closed, ResolvedPublic

Description

System Information
Windows 10 64-bit, Nvidia 1060

Blender Version
Broken: Current 32-bit 2.80 daily
blender-2.80-4dd0a90f4213-win32

Short description of error
Blender intermittently fails to start, fails to read date/hash, silently quits opening .blend, throws exception on exit, etc.

Exact steps for others to reproduce the error
After reading

https://devtalk.blender.org/t/bl-2-80-beta-will-not-run-on-win-10/4757

I downloaded the current 2.80 32-bit beta and it definitely seems to have issues, at least running on top of current Windows 64-bit (I don't have a 32-bit system to test on currently).

It will fail to start (exits silently) most (all?) of the time when started normally.
It will start when run with --debug, but throws an EXCEPTION_ACCESS_VIOLATION if you immediately quit.
Opening any .blend file has about a 50% chance of causing an immediate exit with the same exception.
The --debug output shows "Version 280 sub 39 date unknown hash unknown" about half the time, but the rest of the time it finds the date and hash successfully.

Details

Type
Bug

Event Timeline

Can't reproduce on win64, try starting with --factory-startup and see if that helps.

LazyDodo (LazyDodo) triaged this task as Needs Information from User priority.Jan 2 2019, 10:02 PM

Running with --factory-startup makes no difference in the behavior that I can detect. Out of the box it just exits silently.

Ah, it did that four times in a row and then finally started correctly on the fifth try.

It's definitely some kind of non-deterministic uninitialized variable kind of thing.

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jan 15 2019, 12:56 PM
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Jan 24 2019, 5:29 PM

Is this still a problem with the latest blender beta?

With today's 2.80 32-bit download I still get the same behaviors. Silently exits unless you add --debug, and then it's working sort of OK, though one file fails to render objects in Cycles, and I get various errors in the process of opening random .blend files (some of which may be old 2.79 format), and it generally crashes when I exit.

Memoryblock reconstruct: end corrupt
Memoryblock reconstruct: end corrupt
Memoryblock reconstruct: end corrupt
Memoryblock reconstruct: end corrupt
Memoryblock reconstruct: end corrupt
Memoryblock reconstruct: end corrupt
Memoryblock reconstruct: end corrupt
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x3F800000

Again, this is just be trying out 32-bits on a 64-bit Windows because other people reported issues with it. I don't have a true 32-bit Windows system to test on, and have no personal need for 32 to work on 64, so my only concern was whether this represents an actual issue which would affect users on 32-bit platforms.

I have, i can't reproduce

@Brecht Van Lommel (brecht) do you guys have any windows computers to reproduce this on?

Gavin Scott (Zoot) added a comment.EditedJan 24 2019, 8:29 PM

If it doesn't reproduce for LazyDodo then I'm not sure it's worth worrying too much about at the moment, unless and until a real 32-bit user comes along with issues, so I have no problem if you want to close this one.

There might be some fundamental 32-bit environment issue here that I don't normally see because I don't run similar 32-bit applications. As long as it works for someone then I'm not going to worry that it's completely broken which was my original concern.

seems similar to T59926
Haven't realized, this may be only present in 32bit build. i switched to 64, haven't noticed bug anynore and closed it.
I can still reproduce also T59927 on 32-bit

Does it work if you run the 32bit version in compatibility mode with win7 (32bit) ?

I've had an other user report that on win7 64bit he also got this issue, but after running it in compatibility mode, this doesn't happen (even when switching it off afterwards).

Seems like people had problems like this with java too https://stackoverflow.com/questions/8921607/jvm-32-bit-crashes-on-64-bit-machine

Quick tests don't show any apparent difference with Windows 7 compatibility mode.

I never bothered setting to Win7 compatibility.
The default target in Win7 is WinXp SP3.
For my Win10 (laptop) test, I used the default Win8 target.

The compatibility switch on/off thing didn't stick on Win10.

as for me the "compatibility with windows 7" trick works

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mar 11 2019, 3:19 PM

The 32 bit build also crashes sometimes on startup for me, but not consistently.
Sometimes I also get

Memoryblock reconstruct: end corrupt

in the log.
Would it help if I did a 32 bit debug build myself to see where it crashes?

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.Apr 2 2019, 4:15 PM

Please try again with the very latest 2.80 32bit build:
https://builder.blender.org/download/

rB4f4cea727efd: Fix T63164: DNA size mismatches on 32bit, causing memory corruption and crashes. may have fixed some or all of these issues.

works great for me now, no crash anymore (so far).

Brecht Van Lommel (brecht) closed this task as Resolved.Apr 2 2019, 4:58 PM
Brecht Van Lommel (brecht) claimed this task.

Let's assume this is fixed then.

If there are more specific steps to crash Blender, best to open a new report.

I can confirm that it appears fixed here too! 32-bit running on top of Windows 10 64-bit.

Thanks Brecht!