Page MenuHome

Transform tool - Gizmo mode not updated in viewport
Closed, ResolvedPublic

Description

System Information
Operating system: Linux Kernel: 4.15.0-43-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.8 Distro: Linux Mint 19.1 Tessa
Graphics card: NVIDIA GT218 [NVS 300], Display: x11 server: X.Org 1.19.6 driver: nouveau

Blender Version
Broken: 2.80, 4dd0a90f4213, blender2.8, 2019-01-01)


When changing the Gizmo mode from Move to Rotate or Scale (or any other combination), the corresponding gizmo handlers are not updated in viewport.

  1. New file with factory settings
  2. Select the cube and then click the Transform tool in the left side toolbar
  3. Click the Move/Rotate/Scale text buttons at the top of the window (not the tool buttons in the left side toolbar)

Expected result: gizmo handlers of the selected cube to change the same way as when selecting the tool buttons on the left.
Obtained result: nothing changes in viewport
Workaround: select another object and then select back to cube to see the change.

Event Timeline

voxel9 created this task.Jan 3 2019, 12:30 PM
Sebastian Parborg (zeddb) lowered the priority of this task from 90 to 30.Jan 3 2019, 12:46 PM

This was fixed recently. Can you retry with a recent build? I can't reproduce this on a build from today.

voxel9 changed the task status from Unknown Status to Resolved.Jan 3 2019, 12:59 PM
voxel9 claimed this task.

Indeed, I just downloaded and tried the build from last night (11f2c65128dc) and it works well.
I close the ticket.